YAST Hardware Information Hangs

Currently running Tumbleweed 20210330 5.11.6-1-default x86_64
Started Yast, attempted to run Hardware Information as I’ve done for years. It hangs while probing for DSL, which is the first thing it looks for. The only way to terminate it is with kill or XKill. It has done this since the last couple of updates performed over the past month or so. Has anyone else had this problem?

I have seen the same. It happens also with ncurses verion of Yast. However, runnig hwinfo straight from the cli works just fine.

You might find the desired information using inxi. By default the information it shows is rather limited, but it has a multitude of options that provide more detail in various forms. Be sure you have the latest version 3.0.3 installed, which just became available on the mirrors several days ago.

A thing that I almost never use, but just tried today, “Hardware Information” in Yast and indeed it hangs in DSL. What is bad is that also the Abort button does not work

Using “ps aux” it seems to be running:

[FONT=monospace]/bin/bash /sbin/yast2 hwinfo
   /usr/bin/ruby.ruby2.7 --encoding=utf-8 /usr/lib/YaST2/bin/y2start hwinfo qt -name YaST2 -icon yast[/FONT]

Killing (with “kill -9”) the second process works, a normal kill does not work.
Did run the second line as root on the console and then the ncurses version comes up, same problem.
Had a look on the Internet and see you can start the Ruby debugger adding “-rdebug”:

/usr/bin/ruby.ruby2.7 -rdebug --encoding=utf-8 /usr/lib/YaST2/bin/y2start hwinfo qt -name YaST2 -icon yast

The debugger I know, it like the one in Perl.

With some iterations (also in the debugger it hangs if you just run and do not single-step, Ctrl-Z + kill %1 brings you out) I see [FONT=arial]/usr/share/YaST2/clients/hwinfo.rb is executed. Running that stand-alone is not possible as it needs some Yast::Client so there my debugging ends for now.

Confirmed by another user: Bug report?

Yes, i can confirm the behavior described in the first post.

Operating System: openSUSE Tumbleweed 20210330
KDE Plasma Version: 5.21.3
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2
Kernel Version: 5.11.6-1-default
OS Type: 64-bit
Graphics Platform: X11
Graphics Processor: Mesa DRI Intel® HD Graphics 630

However i probably never used YaST -> Hardware Information before so i don’t know if it has been working in the past.



Created https://bugzilla.opensuse.org/show_bug.cgi?id=1184339

Anybody on Tumbleweed for who YaST 2 “Hardware Infomation” is working fine?

Gooood! :good:

Meanwhile there is a patch which has been approved so I expect that in some coming Tumbleweed update a fix is coming.

Thanks for the information !



Just tried Yast → Hardware Information and it no longer hangs, fix released.

> cat /etc/os-release 
NAME="openSUSE Tumbleweed" 
# VERSION="20210420"