Yast freezing up

Hello all! I am having some issues when trying to open Yast to adjust
some of the boot settings. I open Yast and then put in the password.
Next click system and then Boot Loader, Kernel Settings, or System
Backup and the machine freezes. It also froze when going into Security
and Users and clicking on Local Security. It did not freeze when going
into Hardware>Mouse Model.

Any help much appreciated, thanks!!


2quick

2quick’s Profile: http://forums.opensuse.org/member.php?userid=17255
View this thread: http://forums.opensuse.org/showthread.php?t=406124

Is this a new install? 11.1?

Has Yast previously been OK?

If you start yast from a terminal does it show any errors in the
terminal, this how, open a terminal and go su and then type:

yast2

If you just do :

yast

you will get the text version


Box: Linux 2.6.27.9-159 i686 | Fedora 10 | Gnome 2.24.2 | M2N4-SLI | AMD
64 X2 5200+ | nVidia 8500GT | 2GB RAM
Lap: OS 11.1 | Celeron 550 | (KDE4.1.96)"78.2"rc1 | Intel 965 GM |
Lenovo R61e | 3GB RAM

caf4926’s Profile: http://forums.opensuse.org/member.php?userid=204
View this thread: http://forums.opensuse.org/showthread.php?t=406124

caf4926;1934260 Wrote:
> Is this a new install? 11.1?
>
> Has Yast previously been OK?
>
> If you start yast from a terminal does it show any errors in the
> terminal, this how, open a terminal and go su and then type:
>
> yast2
>
> If you just do :
>
> yast
>
> you will get the text version

Sorry for the lack of OS details. I am using OpenSUSE 11.1 with KDE
4.1.3

This is a relatively new install, but this was not an issue before. I
was adjust some video settings, but that is about it.

When you in a new terminal you mean using Ctrl+Alt+F1, correct? When
doing this and typing Yast2 or Yast it open the blue screen and the same
menu options in KDE, obviously a different format thought. Also I am
able to go into the menus as well. Thanks!


2quick

2quick’s Profile: http://forums.opensuse.org/member.php?userid=17255
View this thread: http://forums.opensuse.org/showthread.php?t=406124

I actually was meaning running yast2 from a terminal in the desktop.
It’s possible that it could have some indications.

Ctrl-Alt-F1 (I didn’t dare mention that option) But it will not reveal
the errors you might get whilst X is running.

And the fact that you mention you have altered some video settings
makes me suspect this (by video you mean graphics??)


Box: Linux 2.6.27.9-159 i686 | Fedora 10 | Gnome 2.24.2 | M2N4-SLI | AMD
64 X2 5200+ | nVidia 8500GT | 2GB RAM
Lap: OS 11.1 | Celeron 550 | (KDE4.1.96)"78.2"rc1 | Intel 965 GM |
Lenovo R61e | 3GB RAM

caf4926’s Profile: http://forums.opensuse.org/member.php?userid=204
View this thread: http://forums.opensuse.org/showthread.php?t=406124

I did it in the Konsole as well with the same results, as working with
Yast. But when typing yast2 the window comes up and the same whole
system freeze happens.

What was changed was: Updated the Nvidia driver manually (“hard way”)
to 180.22

Also I ran these commands:

Code:

nvidia-xconfig --composite
nvidia-xconfig --render-accel
nvidia-xconfig --add-argb-glx-visuals -d 24

Here is a link to the log, if this helps out any:
‘mylogfile.txt - nopaste.com (beta)’
(http://www.nopaste.com/p/amaqXV3arb)

I am not sure what exactly to look for in it. Thanks again!!!


2quick

2quick’s Profile: http://forums.opensuse.org/member.php?userid=17255
View this thread: http://forums.opensuse.org/showthread.php?t=406124

In kde4
Desktop effects are enabled via Config Desktop - Desktop - Effects -
All Effects

All I did was install the driver for nvidia.

Just take you time and see how everything else performs.

You could re-install the kernel, then the nvidia driver, check that 3D
is enabled in Yast Graphics Card and you have the correct display.

Then go back to Config Desktop - Desktop - Desktop Effects enable


Box: Linux 2.6.27.9-159 i686 | Fedora 10 | Gnome 2.24.2 | M2N4-SLI | AMD
64 X2 5200+ | nVidia 8500GT | 2GB RAM
Lap: OS 11.1 | Celeron 550 | (KDE4.1.96)"78.2"rc1 | Intel 965 GM |
Lenovo R61e | 3GB RAM

caf4926’s Profile: http://forums.opensuse.org/member.php?userid=204
View this thread: http://forums.opensuse.org/showthread.php?t=406124

After disabling the desktop effects, Yast opened up the window without
freezing.

So now you suggesting reinstalling the kernel, driver, and monitor.
Then turning the settings back on?

Thanks!


2quick

2quick’s Profile: http://forums.opensuse.org/member.php?userid=17255
View this thread: http://forums.opensuse.org/showthread.php?t=406124

I was just suggesting you re-install the kernel, that will break your
current video driver. Then re-install the nvidia driver. Thats it. Just
check it shows 3Din Yast monitor and your screen size is OK.

Then just use kde4’s Cofig Desktop to enable/disable desktop effects.

The desktop effects rolled in to kde4 are really good.


Box: Linux 2.6.27.9-159 i686 | Fedora 10 | Gnome 2.24.2 | M2N4-SLI | AMD
64 X2 5200+ | nVidia 8500GT | 2GB RAM
Lap: openSUSE 11.1 | Celeron 550 | (KDE4.2.0)“82.1” | Intel 965 GM |
Lenovo R61e | 3GB RAM

caf4926’s Profile: http://forums.opensuse.org/member.php?userid=204
View this thread: http://forums.opensuse.org/showthread.php?t=406124

What is the best way to re-install the kernel? Thanks, I have never
done that before.


2quick

2quick’s Profile: http://forums.opensuse.org/member.php?userid=17255
View this thread: http://forums.opensuse.org/showthread.php?t=406124

Yast - software management -
search: kernel

you just check the box for your kernel

accept


Box: Linux 2.6.27.9-159 i686 | Fedora 10 | Gnome 2.24.2 | M2N4-SLI | AMD
64 X2 5200+ | nVidia 8500GT | 2GB RAM
Lap: openSUSE 11.1 | Celeron 550 | (KDE4.2.0)“82.1” | Intel 965 GM |
Lenovo R61e | 3GB RAM

caf4926’s Profile: http://forums.opensuse.org/member.php?userid=204
View this thread: http://forums.opensuse.org/showthread.php?t=406124

Currently these are the ones that are checked:

kernel-pae
kernel-pae-base
kernelpae-extra
kernel-pae-source

All for 2.6.27.7-9.1

I noticed that there are a few other kernels, like default or trace.
Is there any reason I should change it from the PAE type? Also if it is
already checked, should I click it once for the “update”?

Thanks so much!


2quick

2quick’s Profile: http://forums.opensuse.org/member.php?userid=17255
View this thread: http://forums.opensuse.org/showthread.php?t=406124

Just check kernel-pae

pae = ‘Physical Address Extension - Wikipedia, the free encyclopedia’
(http://en.wikipedia.org/wiki/Physical_Address_Extension)

suse seems to default to pae in 11.1

It’s fine, just leave it as is

default would be the other option. but just leave it as pae.
when you click on the black tick it will go to a green update cycle


Box: Linux 2.6.27.12-170.2.5 i686 | Fedora 10 | Gnome 2.24.2 | M2N4-SLI
| AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
Lap: openSUSE 11.1 | Celeron 550 | (KDE4.2.0)“82.1” | Intel 965 GM |
Lenovo R61e | 3GB RAM

caf4926’s Profile: http://forums.opensuse.org/member.php?userid=204
View this thread: http://forums.opensuse.org/showthread.php?t=406124

I updated the kernel, then reinstalled the 180.22 driver from nvidia,
then checked the desktops effects. Still freezing up:(

In Sax2 for card it is saying VESA Framebuffer graphics. Is this ok or
should it be saying something to the NVIDIA type? My Computer system
info say this:

Display Info
Vendor: NVIDIA Corporation
Model: GeForce 8200/PCI/SSE2/3DNOW!
Driver: 2.1.2 NVIDIA 180.22

So it looks like it is good. Any thoughts?

Thanks for the help!!!:slight_smile:


2quick

2quick’s Profile: http://forums.opensuse.org/member.php?userid=17255
View this thread: http://forums.opensuse.org/showthread.php?t=406124

In a terminal type

glxgears

what happens

and:

glxinfo

Paste top section here


Box: Linux 2.6.27.12-170.2.5 i686 | Fedora 10 | Gnome 2.24.2 | M2N4-SLI
| AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
Lap: openSUSE 11.1 | Celeron 550 | (KDE4.2.0)“82.3” | Intel 965 GM |
Lenovo R61e | 3GB RAM

caf4926’s Profile: http://forums.opensuse.org/member.php?userid=204
View this thread: http://forums.opensuse.org/showthread.php?t=406124

glxgears came up fine, but it did have a quick delay every second or so.
Here is what it said:

Code:

4080 frames in 5.0 seconds = 814.564 FPS
4026 frames in 5.0 seconds = 799.416 FPS
3702 frames in 5.0 seconds = 740.356 FPS
4207 frames in 5.0 seconds = 841.397 FPS
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server “:0.0”
after 737 requests (737 known processed) with 0 events remaining.


2quick

2quick’s Profile: http://forums.opensuse.org/member.php?userid=17255
View this thread: http://forums.opensuse.org/showthread.php?t=406124

Here is the results of the first half of the top section of glxinfo:

Code:

philip@linux-zr3q:~> glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
GLX_EXT_texture_from_pixmap, GLX_ARB_create_context, GLX_ARB_multisample,
GLX_NV_float_buffer, GLX_ARB_fbconfig_float, GLX_EXT_framebuffer_sRGB
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info,
GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync,
GLX_NV_swap_group, GLX_NV_video_out, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_SGI_swap_control, GLX_ARB_create_context, GLX_NV_float_buffer,
GLX_ARB_fbconfig_float, GLX_EXT_fbconfig_packed_float,
GLX_EXT_texture_from_pixmap, GLX_EXT_framebuffer_sRGB,
GLX_NV_present_video, GLX_NV_multisample_coverage
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
GLX_EXT_texture_from_pixmap, GLX_ARB_create_context, GLX_ARB_multisample,
GLX_NV_float_buffer, GLX_ARB_fbconfig_float, GLX_EXT_framebuffer_sRGB,
GLX_ARB_get_proc_address
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 8200/PCI/SSE2/3DNOW!
OpenGL version string: 2.1.2 NVIDIA 180.22
OpenGL extensions:
GL_ARB_color_buffer_float, GL_ARB_depth_texture, GL_ARB_draw_buffers,
GL_ARB_draw_instanced, GL_ARB_fragment_program,
GL_ARB_fragment_program_shadow, GL_ARB_fragment_shader,
GL_ARB_half_float_pixel, GL_ARB_half_float_vertex,
GL_ARB_framebuffer_object, GL_ARB_geometry_shader4, GL_ARB_imaging,
GL_ARB_multisample, GL_ARB_multitexture, GL_ARB_occlusion_query,
GL_ARB_pixel_buffer_object, GL_ARB_point_parameters, GL_ARB_point_sprite,
GL_ARB_shadow, GL_ARB_shader_objects, GL_ARB_shading_language_100,
GL_ARB_texture_border_clamp, GL_ARB_texture_buffer_object,
GL_ARB_texture_compression, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_dot3, GL_ARB_texture_float,
GL_ARB_texture_mirrored_repeat, GL_ARB_texture_non_power_of_two,
GL_ARB_texture_rectangle, GL_ARB_transpose_matrix,
GL_ARB_vertex_array_object, GL_ARB_vertex_buffer_object,
GL_ARB_vertex_program, GL_ARB_vertex_shader, GL_ARB_window_pos,
GL_ATI_draw_buffers, GL_ATI_texture_float, GL_ATI_texture_mirror_once,
GL_S3_s3tc, GL_EXT_texture_env_add, GL_EXT_abgr, GL_EXT_bgra,
GL_EXT_blend_color,


2quick

2quick’s Profile: http://forums.opensuse.org/member.php?userid=17255
View this thread: http://forums.opensuse.org/showthread.php?t=406124

And the second half:

Code:

GL_EXT_blend_equation_separate,
GL_EXT_blend_func_separate, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
GL_EXT_compiled_vertex_array, GL_EXT_Cg_shader, GL_EXT_bindable_uniform,
GL_EXT_depth_bounds_test, GL_EXT_direct_state_access,
GL_EXT_draw_buffers2, GL_EXT_draw_instanced, GL_EXT_draw_range_elements,
GL_EXT_fog_coord, GL_EXT_framebuffer_blit, GL_EXT_framebuffer_multisample,
GL_EXT_framebuffer_object, GL_EXTX_framebuffer_mixed_formats,
GL_EXT_framebuffer_sRGB, GL_EXT_geometry_shader4,
GL_EXT_gpu_program_parameters, GL_EXT_gpu_shader4,
GL_EXT_multi_draw_arrays, GL_EXT_packed_depth_stencil,
GL_EXT_packed_float, GL_EXT_packed_pixels, GL_EXT_pixel_buffer_object,
GL_EXT_point_parameters, GL_EXT_rescale_normal, GL_EXT_secondary_color,
GL_EXT_separate_specular_color, GL_EXT_shadow_funcs,
GL_EXT_stencil_two_side, GL_EXT_stencil_wrap, GL_EXT_texture3D,
GL_EXT_texture_array, GL_EXT_texture_buffer_object,
GL_EXT_texture_compression_latc, GL_EXT_texture_compression_rgtc,
GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
GL_EXT_texture_integer, GL_EXT_texture_lod, GL_EXT_texture_lod_bias,
GL_EXT_texture_mirror_clamp, GL_EXT_texture_object, GL_EXT_texture_sRGB,
GL_EXT_texture_shared_exponent, GL_EXT_timer_query, GL_EXT_vertex_array,
GL_EXT_vertex_array_bgra, GL_IBM_rasterpos_clip,
GL_IBM_texture_mirrored_repeat, GL_KTX_buffer_region, GL_NV_blend_square,
GL_NV_copy_depth_to_color, GL_NV_depth_buffer_float,
GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_explicit_multisample,
GL_NV_fence, GL_NV_float_buffer, GL_NV_fog_distance,
GL_NV_fragment_program, GL_NV_fragment_program_option,
GL_NV_fragment_program2, GL_NV_framebuffer_multisample_coverage,
GL_NV_geometry_shader4, GL_NV_gpu_program4, GL_NV_half_float,
GL_NV_light_max_exponent, GL_NV_multisample_coverage,
GL_NV_multisample_filter_hint, GL_NV_occlusion_query,
GL_NV_packed_depth_stencil, GL_NV_parameter_buffer_object,
GL_NV_pixel_data_range, GL_NV_point_sprite, GL_NV_primitive_restart,
GL_NV_register_combiners, GL_NV_register_combiners2,
GL_NV_texgen_reflection, GL_NV_texture_compression_vtc,
GL_NV_texture_env_combine4, GL_NV_texture_expand_normal,
GL_NV_texture_rectangle, GL_NV_texture_shader, GL_NV_texture_shader2,
GL_NV_texture_shader3, GL_NV_transform_feedback,
GL_NV_transform_feedback2, GL_NV_vertex_array_range,
GL_NV_vertex_array_range2, GL_NV_vertex_program, GL_NV_vertex_program1_1,
GL_NV_vertex_program2, GL_NV_vertex_program2_option,
GL_NV_vertex_program3, GL_NVX_conditional_render, GL_SGIS_generate_mipmap,
GL_SGIS_texture_lod, GL_SGIX_depth_texture, GL_SGIX_shadow,
GL_SUN_slice_accum
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess


2quick

2quick’s Profile: http://forums.opensuse.org/member.php?userid=17255
View this thread: http://forums.opensuse.org/showthread.php?t=406124

Well how about the all important /etc/X11/xorg.conf

and have you tried desktop effects in kde4?

and what version of kde4 are you using? Many have upgraded to 4.2


Box: Linux 2.6.27.12-170.2.5 i686 | Fedora 10 | Gnome 2.24.2 | M2N4-SLI
| AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
Lap: openSUSE 11.1 | Celeron 550 | (KDE4.2.0)“82.4” | Intel 965 GM |
Lenovo R61e | 3GB RAM

caf4926’s Profile: http://forums.opensuse.org/member.php?userid=204
View this thread: http://forums.opensuse.org/showthread.php?t=406124

Here is the link to the xorg.0.log file:

‘Xorg.0.log - nopaste.com (beta)’ (http://www.nopaste.com/p/aEXa38vcC)

I am not quite sure what you mean by desktop effects in KED4, sorry.

I am using KDE 4.1.3 Release 4.9. I am unsure as to how to update to
4.2. First I should remove the 4.1 repositories in and then add the
4.2. Then install all the 4.2 items? Thanks!


2quick

2quick’s Profile: http://forums.opensuse.org/member.php?userid=17255
View this thread: http://forums.opensuse.org/showthread.php?t=406124

Actually that file is a log file not xorg.conf

To upgrade to 4.2
Yes if you have added 4.1 repos from the build service, disable them.
Then add these:

‘Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1+Qt45’
(http://tinyurl.com/b8kb99)

‘Index of /repositories/KDE:/KDE4:/Factory:/Extra-Apps/openSUSE_11.1’
(http://tinyurl.com/76brcy)

‘Index of
/repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE4_Factory_Desktop’
(http://tinyurl.com/a2s2ca)

Then from software Management - Repositories Filter -

Visit each of the 3 new repo’s (you may have nothing installed from
extra)

and from the Packages tab at the top of your screen
select Update all in this list unconditionally
then accept

You may have to work through some dependencies (like allow deletion of
Power devil, I think there is a compiz one also).

If you can’t figure it out - ask back here


Box: Linux 2.6.27.12-170.2.5 i686 | Fedora 10 | Gnome 2.24.2 | M2N4-SLI
| AMD 64 X2 5200+ | nVidia 8500GT | 2GB RAM
Lap: openSUSE 11.1 | Celeron 550 | (KDE4.2.0)“83.1” | Intel 965 GM |
Lenovo R61e | 3GB RAM

caf4926’s Profile: http://forums.opensuse.org/member.php?userid=204
View this thread: http://forums.opensuse.org/showthread.php?t=406124