Yast error

I have been trying differnt distro’s out this week in an attempt to eventually leave windows behind, Ive tried ubuntu,Fedora and am finding this my favorite… Anyhow

My problem is after getting most software i want updated via Yast2

I have started getting the following error when trying to install anything"

YaST got signal 11 at YCP file /usr/share/YaST2/clients/inst_packages.ycp:49 

/sbin/yast2: line 421: 21620 Segmentation fault   $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

I have searched everywhere and can not find a fix

Anyone have an idea to fix my problem

System specs hp dv9750us laptop
openSuse 11.0 with gnome

sorry if i posted this in the wrong forum , i hope i got it right

Check this thread
YaST/zypper segmentation fault - openSUSE Forums

seems to be similar
you have to get to the end to see the way it worked out
was related to repo’s from 10.3 being added to 11 sys

to check your repos
in a terminal type

zypper lr -u

post here if you like