YaST Doesn't Allow Spaces in SSID

I’m using the “yast lan” command-line tool to configure wireless networks. In “Wireless Device Setting” where you enter the SSID, it does not allow me to enter spaces in the SSID name. Scanning works and picks up the SSID with spaces just fine, but sometimes I set up devices before I ship them off. I came up with a workaround where I scan for SSIDs, then pick one with a space, and manually edit around the space to have it included, but this is not practical or expected behavior. I can’t even copy the SSID name, login using Putty, and then “Shift+Enter” to add the name - it removes the space!

Am I doing something incorrectly?
Should I file a bug for this?

Thanks for any help.

I’ve never used that command line tool. But it looks as if it should do the same as

Yast → System → Network Settings

I just tried that to setup WiFi (I normally use ethernet). It did not seem to have any problem with the space in the name. However, the network failed to connect. I then tried again, but this time I used search for network. And this time it did connect.

The connection file “/etc/sysconfig/network/ifcfg-wlan0” seemed to be the same both ways of doing it.

On systems where I use WiFi, I normally use NetworkManager to configure.

Tried to escape the space with a forward slash…

my\ funky\ ssid

We have used wicked for ages. Really bizarre behavior.

I assume that this is about the YaST ncurses interface.

When that is correct, I assume also that the OP is not able to use the YaST GUI interface (else he would probably have used it).

@malcolmleweis: do you mean that you tried it and then succeeded? Or do you just suggest to use bash escaping?

And at last to the OP: when you think this is worth a bug report, then you should at least upgrade to a supported version of openSUSE (15.2 or 15.3) and re-create the problem there. Nobody will accept a bug for unsupported software versions.

Yes, just a suggestion.

Yeah exactly, this is using the ncurses interface, the GUI isn’t included with our build. I’ll try on newer versions and file a bug if it still persists. Thank you.

Presumably yes. I am using SSID = ‘FRITZ!Box Karl Mistelberger’ since ever and never experienced any issues.