Yast does not wait for a connection to be established before checking for updates

Hello All,

I’ve recently installed Leap 15 from clean. Since the installation, I get this annoying issue: Yast tries to search for updates right at the startup, before I actually have the time to open kwallet to enable the wifi. As a result, I get this pop-up error message:

Download (curl) error for 'https://download.nvidia.com/opensuse/leap/15.0/repodata/repomd.xml':
Error code: Connection failed
Error message: Could not resolve host: download.nvidia.com

Now the message is technically true, as at the time Yast checks for updates there is no internet connection yet, hence no host could be resolved. Now, this would be just an annoying pop-up error message if Yast would check again a few minutes later and then find the connection, the very annoying thing is that Yast stops checking alltogether and I have to force it manually.

Any suggestion on how to get rid of the issue?

I suppose you mean your desktop’s update notifier, not YaST (which shouldn’t be started automatically on login anyway, and I wouldn’t really see any point in doing so).

That’s a bug:
http://bugzilla.opensuse.org/show_bug.cgi?id=1073610

A workaround (other than disabling the updater completely) would be to make the WLAN connection a “system connection” (activate “Allow all users to connect” in the connection settings), and store the password system-wide (can be set on the “WiFi Security” tab in the connection settings).
The connection should be established during boot then already, before you log in.
(small disadvantage: you’d need to enter the root password to make any changes to the connection settings, but there normally shouldn’t be a need to change them anyway)

Or use wicked instead of NetworkManager, but then you won’t have any desktop applet to control the network connections and would need to use YaST to configure them.

PS:

AFAIK KDE/Plasma’s updater should actually check again after an hour in that case.
I’m not sure though, and you didn’t mention which desktop you are using either (kwallet probably does indicate Plasma though… :wink: ).

Thanks for the insight!

Yes, I was actually referring to the desktop notifier, and yes again, I am using KDE.
If it’s a known bug I would probably wait for that to be fixed, rather than going for the workaround; I already had to manually edit /etc/resolv.conf to make my laptop “see” the DNS server (as in: https://forums.opensuse.org/showthread.php/531269-2-possible-problems-DNS-resolution-and-quot-Networking-disabled-quot), I’d rather not play with the internet settings again

Many thanks for your help anyway

I have no idea how long it will take to fix it though.
So far, none of the GNOME/PackageKit maintainers has even responded…

I already had to manually edit /etc/resolv.conf to make my laptop “see” the DNS server (as in: 2 possible problems: DNS resolution and "Networking disabled" - Network/Internet - openSUSE Forums), I’d rather not play with the internet settings again

Allowing all users to connect is not really “play with the internet settings” and should not possibly cause any problems at all.
You likely will have to re-enter the password (once) though.

Btw, I use this since years, for other reasons.
One advantage is that you also have an Internet connection when logging in to text mode e.g., despite using NetworkManager.

It’s your decision of course though.

I’ve found something very similar:
https://bugs.kde.org/show_bug.cgi?id=394961
You can patch the main.qml file of the update applet by yourself.