YaST does not start

Hello All,

I am using OpenSuse 10.3. After a recent update I cannot start the Install/deinstall software under YaST any more. I get the following error message when I try to open Inastall/Deinstall sowtware:
YaST got signal 11 at YCP file /usr/share/YaST2/clients/sw_single.ycp:187
/sbin/yast2: line 386: 30609 Segmentation fault****$ybindir/y2base $module “$@” “$SELECTED_GUI” $Y2_GEOMETRY $Y2QT_ARGS

I read through the forums for this error message and the solution given in many places, which worked ok for everybody with the same problem, does not work for me. I am talking about executing as root the following commands:

  • remove /var/cache/zypp/zypp.db and /var/cache/zypp/zypp.db-journal
  • then run ‘zypper refresh’

When I run zypper refresh my zipp.db file is created, but it is empty and it is giving me the following eror message in the console:

Segment violation

Does anybody have any idea what my problem is?
Many thanks in advance


One thing to try is to install “Smart”; setup the oss-repro; refresh
Expand RPM System
Page down to Yast rpms
right click each and select “reinstall”

When you are done, in a terminal as root, run "SuSEconfig

See if that helps?

Hey man,

thanks for the advise! But it does not work, because it has a whole bunch of dependancies (around 30 for the rpm-python which is needed for the smart installation )…it is a nightmare (an impossible one) to go over this without something like YaST.
I guess it is not only the YaST that had gone wrong after this awful update!

does anybody have other ideas how can I solve my problem??



Have you tried running the text version of YaST from a console?

As root user type yast at the command line and see if this will run.

Yes, I tried the text version, but even though it is not writing down the error message, it is not showing the software packages installed…so it does not work this way either :frowning:

do you think it is possible (and if yes, how) to downgrade, so I can have everything running like in the good old times(last week)? is this reasonable at all???

Thread moved to Applications