Yast:Could not resolve host: download.opensuse.org;

Hello
I installed OpenSuse 12.3 on Compaq CQ58. I Checked off IPV6, network is ok on lan and Wifi, Firefox is surfing fine on Internet but Yast is failing since it can’t connect to repositories. The message I receive from Yast is:could not resolve host: download.opensuse.org.
I have the standard repositories enabled. It seems to me that Yast is not able to use dns, I made a test changing the repositories IP name with IP address on the Repositories Panel,I changed from download.opensuse.org to 195.135.221.134 and Yast started working for a short time till it had to deal again with IP name download.opensuse.org.
The contents of /etc/resolv.conf is : nameserver 192.168.1.1 (it’s my router IP address)
I have no idea how solve this problem, I installed OpenSuse three times with the same error.
Thanks in advance for any help

 Giorgio

First test that DNS server to be sure with e.g.

nslookup www.google.com

When this does not resolve, your DNS server does not work properly.

On 03/15/2013 06:26 PM, GioSint wrote:
> could not resolve host: download.opensuse.org

are you behind a proxy?


dd

Hello
No proxy configured,
nslook up command follows

nslookup Google
Server: 192.168.1.1
Address: 192.168.1.1#53

Non-authoritative answer:
Name: Google
Address: 173.194.35.177
Name: Google
Address: 173.194.35.178
Name: Google
Address: 173.194.35.179
Name: Google
Address: 173.194.35.180
Name: Google
Address: 173.194.35.176

So your DNS server functions! That is strange because of the error you get with YaST.

You could try

nslookup download.opensuse.org

but I admit that I do not realy understand what is going on here (like most problems that seem to switch themselves on and off at random :frowning: ).

BTW, when you post computer output as above, please do so between CODE tags. You get them by clicking on the # button in the toolbar above the post editor. We prefer the prompt, the command, the output and the next prompt in one sweep of the mouse copied/pasted between those CODE tags.

Hi
nslookup command follows, I hope I put the data in the correct way,

nslookup download.opensuse.org
Server:         192.168.1.1
Address:        192.168.1.1#53

Non-authoritative answer:
Name:   download.opensuse.org
Address: 195.135.221.134


Have you, by any chance, defined your domain name to be “opensuse.org” in your router?

Some routers seem to assume that the domain name assigned to the router applies only to LAN hosts.

Hi
I didn’t define any domain name on the router. By the way I have another PC with OpenSuse 12.1 installed on the same router, no problem at all with Yast

Hi
eventually I went on a public Wifi and I discovered Yast had connected to repositories. Everything was fine from there, so the problem is my router. Thanks to everyone for your help

Giorgio

You are welcome

But your last two posts are a bit contradictory. I guess you still have a problem. Wish you success in solving it.

On 03/16/2013 10:06 AM, GioSint wrote:
> the problem is my router.

yes, your nslook up shows your machine is looking to 192.168.1.1 for
domain name service (dns)…i would suggest in router’s setup that
you specify it look to Google’s free DNS service at these addresses:

8.8.8.8
8.8.4.4

the router probably defaults to using your ISP’s DNS, which may or
may not be as fast/reliable as is Google’s…


dd
http://tinyurl.com/DD-Caveat

Hi
I’m not an network expert. I first solved my problem editing Network setting, enabling ifup and defining my ISP static DNS on host name/DNS. Yast worked fine but I couldn’t use wifi, so at the end I followed last post which suggests to change DNS in my router. I changed dynamic DNS to static in my router and defined my ISP DNS there. Then I switched again to Network manager disabling ifup on Network setting.
Now Yast can connect to repositories and wifi is ok
Thanks again to everyone for your help

Giorgio