yast could not connect with my http proxy

Hello all. My box has to connect to internet using specified http proxy.I have set proxy in both kde control center and yast2 control center. They both tell me the proxy works fine. But when I really try to use yast2 to update my system ,it report an error:

Failed to download ./repo/repoindex.xml from http://opensuse.cict.fr/distribution/11.2/repo/non-oss/ history: - [AbstractCommand.cc:195] URI=http://opensuse.cict.fr/distribution/11.2/repo/non-oss/repo/repoindex.xml

even I try

export http_proxy=http://XXXX

in command line,the error still exist.

In debian apt-get and slackware slackpkg,my proxy works fine. So I am sure it is not my fault and maybe it is a bug of yast2.
This is the first time I using opensuse,so any one here can help me?

You need to post your exact setup in YaST>Network Services>Proxy so that we may analyze the problem. This should work for your repositories when setup properly. I am not sure why this problem does not keep Firefox off-line.

Thank You,

Hello jdmcdaniel3.As I have removed Opensuse from my box ,this time I reinstall **Opensuse 11.2 **in vmware to show you how the error occurs.
For saving time, I only install Opensuse in text mode and use yast.

here it is :

proxy setting in yast :




error reported:


but I can using w3m to visit the reposotories:


Sorry, you can find pictures heres:

proxy setting in yast :




error reported:

but I can using w3m to visit the reposotories:


Is that an ISA?
Is yes, then configure the NTLMAPS (NTLM Authorization Proxy Server)
It worked flawlesly in my office.

Thank you sir,but my proxy server is not a NTLM Authorization Proxy Server.

Check your proxy settings in /etc/sysconfig/proxy file.
And try this:

export ZYPP_ARIA2C=0

perhaps it will help.

Thank you sir.I did it.
In /etc/sysconfig/proxy, it did not add my proxy user name and password ,so I modified it like
http://username:password@proxy:port.And it now works.

I was puzzled why This is not modified automatically since I had input it in yast/yast2.