Yast ca module in 15

Does anyone know if the yast ca module is due to be in 15
or has it been dropped for some reason ?



Been awhile since I’ve looked at graphical CA tools…
I seem to remember I wasn’t particularly fond of any I tried and generally used whatever was recommended for the purpose of that CA.
And at least for me, I didn’t think the YaST CA manager was capable enough.

I remember that I did use TinyCA for a short while…



I tried that - it just blows up with -

Can’t use ‘defined(@array)’ (Maybe you should just omit the defined()?) at /usr/share/TinyCA2/lib/GUI.pm line 1252.
Compilation failed in require at /usr/bin/tinyca2 line 35.
BEGIN failed–compilation aborted at /usr/bin/tinyca2 line 35.

I haven’t had a chance to look into why yet !

I can do it the ‘hard way’ but I quite liked the Yast one - it worked well setting up common server certs that directory servers etc could use.
( BTW I think the new authentication server setup is horrible compared to 42.n and before ) It sort of worries me that Yast in openSUSE is
drifting away from why we chose openSUSE in the first place - First Yast lost the autohome module and now the ca one. Yast used to be a
one stop shop. I can’t believe we are an atypical usage scenario but they do seem to be making things **** difficult sometimes.

end of Friday rant :slight_smile:

BTW the stars are not a swear word. I am amazed it got censored !

Took a look at TinyCA.
Looks like it’s broken across the board (all packages for all distros including all versions of openSUSE and SUSE).
Can’t tell if it’s a Perl problem(I don’t write Perl, but the script is not that hard to read), the array object should be created but fails. Don’t know why the Perl script uses an “If” statement to create the object without providing for a failure option (A Perl coder should probably fix that if it’s a mistake). Would also seem to me that if a dummy config with an existing array were provided, that might also be a way to address (Is that why the “if” statement?).

Seems only the GUI part is broken if you disable the GUI compilation (some help that is!)

Recommend that you submit a bug report to https://bugzilla.opensuse.org so it can be assigned to someone


On investigation it seems there is a bug report for this
It is broken in all version of openSUSE :frowning:

I think I will raise a bug for the CA module in Yast
and see if it gets accepted or a wontfix


Late… but…

Install xca. It seems to be the best (only!) full cert handler out there.

There are old versions within the community repositories, but installing from source is fairly painless provided you have installed the correct devel libs.


Looks like a nice app.
Good list of features.
Some guides and documentation, examples.

When you run into an app where only old versions are available in the OSS, submit a bug request to update to httpsL//bugzilla.opensuse.org