[YaST] Bug in scrolling while moving the mouse

I’m testing the openSUSE 13.2 Beta with KDE on a 64 bit system. I’ve noticed a strange behavior in text components of YaST modules (K Menu -> Computer -> YaST -> Release Notes or from the desktop “Install” shortcut). If you try to scroll while moving the mouse automatically the scroll bar restart from the beginning.

Do i have to file a bug? If so, in bugzilla i’ve to file it for openSUSE Factory, right?


[UPDATE] I’ve noticed same behavior with every component of YaST that uses the scrollbar: list boxes, text boxes…

I’m using the same version (openSUSE 13.2 Beta installed from the KDE Live CD) and in the software manager I have the same bogus scrolling behavior.

Not sure whether it’s YaST or Qt, but I still raised a bug report to investigate: http://bugzilla.opensuse.org/show_bug.cgi?id=898830

You might want to subscribe to that one :slight_smile:

I tried following the instruction, both in the OP and in that bug report.

I am not seeing any problem. Everything works just as expected.

This is while running factory 20140918.

My best guess: this is a graphics driver issue. I’m using Intel graphics (Ivy bridge) and not having problems.

Maybe you need to mention what graphics card you are using. I suggest you mention that both in this thread and in the bugzilla report.

Sorry, forgot to mention that I installed openSUSE 13.2 beta in Virtualbox, so the problem is maybe related to how mouse events are sent to the VM.

The host system runs openSUSE 13.1 x86_64 and the graphics card is NVidia with the latest proprietary drivers from their repo.

Later on I installed KDE/plasma 5 from factory in that VM and saw the issue happening in KDE’s start menu as well. Did not try in KDE 4.

If needed I can add more details later or do more experiments (on mobile for a few days)

Yes, that’s a possibility.

Since my previous post, I have tried this on 13.2-Beta1 with Intel graphics (Haswell), and there was no problem. And I tried with another factory (20140918) installation and a Nvidia 6150 LE with the Nvidia driver. Again, no problem.

A thought occurs to me. If you follow the factory mailing list, they are reporting problems in the latest unpublished factory test. The problems are graphic – in KDE, apparently the panel crashes. I’m now wondering if those problems could also be caused by the VirtualMachine setup for openQA testing. (Okay, just thinking aloud here with off-topic thoughts).

i forgot some info: I’ve installed openSUSE 13.2 Beta1 on a VirtualBox VM.
Hardware specs: Intel Core i5 at 2.66 Ghz, 8 GB of RAM and ATI HD5830 as videocard.