Yast behaving strange

I have just updated my second computer to Leap42.1/KDE - it is a Asus laptop K52F. There something strange happens with Yast. When I open it from the application launcher everything (as far as I tried - Repositories, Online Update, Boot Loader, etc) seems to work except the Software Management button. There the window opens, checks the repositories and then the software management window crashes. I have tried it several times yesterday and today and it is the same thing. However when I go into the terminal, switch to su - and type yast2 then everything works fine including the software management window.
I have checked the command behind the application launcher icon is “/usr/bin/xdg-su -c /sbin/yast2”. Now that is not a big problem since I can always open yast from the commandline but still I would like to fix this. Any ideas?
The other thing I would like to mention - in the Firewall settings in 13.2 I had the ethernet and wlan connection assigned to “external”. After the upgrade they were set to “not assigned”. Normally after an upgrade this was not changed (with one exception some time ago and this was mentioned in the forums.)

Be sure you don’t have any mixed version repos. ie some from previous and some from leap.

Thanks gogalthorp - here is what I have got:

linux-tl1r:~ # zypper lr -u
#  | Alias                           | Name                                    | Enabled | GPG Check | Refresh | URI                                                                                                                                                                                                                            
 1 | Packman                         | Packman                                 | Yes     | (r ) Yes  | Yes     | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_42.1/                                                                                                                                                             
 2 | download.opensuse.org-non-oss   | Main Repository (NON-OSS)               | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/                                                                                                                                                              
 3 | download.opensuse.org-non-oss_1 | Update Repository (Non-Oss)             | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/42.1/non-oss/                 
 4 | download.opensuse.org-oss       | Main Repository (OSS)                   | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/distribution/leap/42.1/repo/oss/          
 5 | download.opensuse.org-oss_1     | Main Update Repository                  | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/42.1/oss                      
 6 | openSUSE-42.1-0                 | openSUSE-42.1-0                         | Yes     | (r ) Yes  | No      | cd:///?devices=/dev/disk/by-id/ata-Optiarc_DVD_RW_AD-7580S_SKA1210559  
 7 | repo-debug                      | openSUSE-Leap-42.1-Debug                | No      | ----      | Yes     | http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/    
 8 | repo-debug-non-oss              | openSUSE-Leap-42.1-Debug-Non-Oss        | No      | ----      | Yes     | http://download.opensuse.org/debug/distribution/leap/42.1/repo/non-oss/
 9 | repo-debug-update               | openSUSE-Leap-42.1-Update-Debug         | No      | ----      | Yes     | http://download.opensuse.org/debug/update/leap/42.1/oss                
10 | repo-debug-update-non-oss       | openSUSE-Leap-42.1-Update-Debug-Non-Oss | No      | ----      | Yes     | http://download.opensuse.org/debug/update/leap/42.1/non-oss/           
11 | repo-source                     | openSUSE-Leap-42.1-Source               | No      | ----      | Yes     | http://download.opensuse.org/source/distribution/leap/42.1/repo/oss/   
12 | repo-update                     | openSUSE-Leap-42.1-Update               | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/42.1/oss/    

I have only added Packman the rest is from the install. They are all for Leap but the repo-debug* and repo-source are disabled - is that as it should be?

I have just removed repo 12 since it is the same as 5


Use the terminal to run yast2 and reinstall yast2-qt
and yast2-gtk

Thank you, conram, I reinstalled yast2-qt-branding-openSUSE, but I could not find any yast2-gtk. Nevertheless I tried opening Yast and Software Management through the application launcher and it works now.
Thank you

There is no yast2-gtk any more.

Nevertheless I tried opening Yast and Software Management through the application launcher and it works now.

Just OOC: do you have two monitors?
It might be this bug then:

A workaround apparently seems to be to uninstall yast2-qt-branding-openSUSE…

You are right, wolfi323, we use this computer with a second monitor. It might only have worked because yesterday because it was in the same window
Hopefully there will be an update soon.