yast (11.2): nothing provides kdebase4-runtime >= 4.3.80 needed by plasmoid-*

I am running KDE 4.3.4 (release 2) with 11.1 x64.

I have the KDE4 Community repo
(http://download.opensuse.org/repositories/KDE%3A/KDE4%3A/Community/openSUSE_11.1_KDE4_Factory_Desktop/)
and yast online updated has recently started throwing errors against new
plasmoid-, kdebase4-workspace, kde4-windeco-* packages, such as:

nothing provides kdebase4-runtime >= 4.3.80 needed by plasmoid-
plasmaboard-0.91-1.8.x86_64

perhaps kdebase4-runtime >= 4.3.80 is forming the basis of KDE 4.4 ?

Hi. Use this repo for KDE 4.3.x: Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.2_KDE_43.
You’re right 4.3.80 is a beta to KDE4.4.
Good luck!

You have mixed your repositories.

Either remove the KDE 4 Community repo (Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE4_Factory_Desktop) and add the KDE 43 Community repo (Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE_43) if you want to stick with KDE 4.3

or remove the KDE 43 repo (Index of /repositories/KDE:/43/openSUSE_11.1) and enable the KDE 4 Factory repo (Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1) if you want to upgrade to KDE 4.4 beta1 (4.3.80).

supertimorplusfort wrote:

>
> Hi. Use this repo for KDE 4.3.x: ‘Index of
> /repositories/KDE:/KDE4:/Community/openSUSE_11.2_KDE_43’
>
(http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.2_KDE_43/).
> You’re right 4.3.80 is a beta to KDE4.4.
> Good luck!
>
>

many thanks !

I also fixed up my KDE Playground repo - now using
http://download.opensuse.org/repositories/KDE:/KDE4:/Playground/openSUSE_11.1_KDE_43