Yas2t Software Management Qt not Starting

i just upgrading to factory from tumbleweed
i follow https://en.opensuse.org/openSUSE:Factory_installation and add games and emulator factory repo
after finish upgrading (zypper dup) i launch yast (now with blue theme) and click software management
but after load configured repositories software management ended and closed automatically
i try run it with command line

kdesu yast2 sw_single

same as above window pop up but after load configured repositories it ended without error
but when i run

sudo yast2 sw_single

terminal showing yast2 software mana gement ncurses without problem

anyone know what the problem and how to fix it?

Does YaST itself work? (i.e. “kdesu /sbin/yast2”)

There are conflicts of the software management module with libproxy1-config-kde4 (used by libzypp) and libqdialogsolver1 (both use libqt4, which causes the libqt5 based YaST to crash) in Factory at the moment, so uninstall them.
At least the first one is installed by default. Btw, the libproxy1-config-kde4 conflict has been fixed yesterday, so the problem should not occur in Factory any more soon (in a few days?).

If that doesn’t help, please post the last lines of /var/log/YaST2/y2log after YaST crashed.

yes it work but it has 2 service managerslol!

that solve my problem thank you
i was trying kept libproxy1-config-kde4 but yast closed when i click accept for installing softwarelol!
am i need to install them again in the future?

One is probably the old and deprecated “Runlevels” modules.
You can uninstall it. (package yast2-runlevel) AFAICS it is not even included in Factory any more.

Btw, this is not at all specific to Factory. Both of them were included in 13.1 already.
By default only the new “Services Manager” is installed, but the older “Runlevels” is kept on upgrades.

am i need to install them again in the future?

Not really, especially if you don’t use a proxy.

This package is a plugin to libproxy1 which enables it to get the proxy settings from KDE.
This is irrelevant for YaST/zypper anyway, as they run as root and therefore cannot even read the user’s KDE settings.
It might be of relevance for other applications (like Firefox or Seamonkey), but normally the proxy settings should be in /etc/sysconfig/proxy anyway which will be respected without that package.

Anyway, if you don’t “taboo” it, it will be installed automatically again anyway. (Keep that in mind in case YaST crashes again)
But as I said, a “fixed” YaST should enter Factory soon (after it has passed the Factory staging tests).

but zypper not found yast2-runlevel when i run zypper remove yast2-runlevel
i only have “runlevel” (systemd-sysvinit) without ‘s’ installed
but yast2 ncurses only show 1 service manager

thanks for the explanation:)

I ran “zypper dup” to update my factory install this morning.
I then reinstalled libproxy1-config-kde4 as a test.
I rebooted, to make sure that there was no dependence on cached information.

After the reboot, Yast is working fine. I’m glad to see that has been fixed.

It was still broken with the 20140728 snapshot, but is fixed with what is currently in the factory repos.

Ok, then you don’t have the old one installed.
JFYI (so that you see what I meant), this is how it looks on my 13.1 installation:
The lower one (“System Services (Runlevels)”) is the old deprecated one, that’s in the package yast2-runlevel.

But, I just booted my Factory VM and I see what you mean.

I also have two entries there, never noticed that before until now.
One is labelled in english and the other one is localized (german in my case).

The reason for this is that yast2-system-manager contains two desktop files: runlevel.desktop and services-manager.desktop
The first one has the line “Hidden=true” so it should not be shown. Probably there’s a (small) bug regarding this in the YaST2 Qt control center, as it seems to ignore that line, or that runlevel.desktop file should not be there (it isn’t in 13.1).

If you want to get rid of the second entry, delete /usr/share/applications/yast2/runlevel.desktop, but this will re-appear when the package gets updated (unless this is fixed already then, of course).
OTOH, I would just ignore it. It’s not really a problem, is it?
Maybe a bug report would be good anyway, though.

no its not really big deal
i thouth i was doing it wrong when upgrading:shame:

AFAICS the fix was not in the Factory repos yet when you posted this, the request to Factory got accepted about 4 hours later according to https://build.opensuse.org/request/show/242961 .
But I don’t see that fixed package in the repo yet.
Maybe just none of your repos had to be refreshed when you tried this? (the crash only occured when refreshing repos or when actually downloading packages)

Anyway, it should be fixed soon in the Factory repo. It just still takes some time to rebuild/republish all changed packages.
You might have to run “zypper dup” or remove libproxy1-config-kde4 a last few times though… :wink:

I discovered that later. I’m not sure why, but Yast software management worked on the first try, but crashed on a later try.

I’ll see what develops with the next round of updates.

AFAICS the fixed yast2 package (3.1.92) is in the repo meanwhile.

I’ll be testing that soon. One of my two factory systems is in the middle of a “zypper dup”.

nrickert wrote:

> wolfi323;2657149 Wrote:
>> AFAICS the fixed yast2 package (3.1.92) is in the repo meanwhile.
> I’ll be testing that soon. One of my two factory systems is in the
> middle of a “zypper dup”.

This system is installed using
openSUSE-Factory-DVD-x86_64-Snapshot20140731-Media.iso / KDE.

Now I updated 102 rpm:s using yast2 from /factory/repo/oss and installed
libproxy1-config-kde4. Everything seems working well.


Yes, it seems to be working well here (after the latest “zypper dup”).