(YAFFI) Yet Another Firefox Issue


I’m running OpenSuse 11.2 KDE 3
Initially FireFox was absolutely fine,
But recently It became utterly slow.

I searched plenty of forums and tweaked the about:config
and played around with ipv6. Some threads suggested downgrading some
x-video thingy coz of an update sadly I haven’t got a clue how to downgrade,
in addition all these threads were talking about rather old OpenSuse versions.
I installed the newest Nvidia driver as some suggested it might have to do with the
desktop effects, actually I just turned them off (literally just this moment) and FF
ran utterly quick, hmm I would like to keep em though.
Does this mean i need to downgrade that xorg-X11-driver-video thingy?

I don’t seem to have a downgrade option I can only update delete and so on…
When clicking on versions it doesn’t show any of the 7.3 only 7.4s.

I kind of depend on some firefox plug-ins which is why I would rather not use another browser…

help would be appreciated

Nope after some exhaustive testing I can now say turning desktop effects (composition) on and off doesn’t do the trick.

And I’m not just talking about tiny delays we’re talking in years here.

so again, anyone any Ideas?


To me this seem to be a problem with the video driver and not with FF. Did you check the very fine instructions given by Oldcpu?

openSUSE Graphic Card Practical Theory Guide for Users

As you are using openSUSE 11.2 with KDE 3 which is not an “official” combination, I suppose it would be nice when you at least unveiled which FF version (and from where) you use, because that could then also be an “unofficial” one. That is of course not a nono per se, but when you want help, it is a piece of information.

You could be right, but why does the OP then only has this with FF? Or is he secretly assuming that we assume that FF is the only application he uses?

Just a feeling from the belly. Slow graphics have the most prominent effect on browsers, but hardly affect terminal windows and the like as much. I may be completely wrong here. Would be interesting to see what ‘top’ says when the browser is slow.

I think the first thing to do is back up (move) configuration folder ~/.mozilla/firefox .

Then try using default firefox configuration (by removing configuration folder). That way you will be sure, that the problem is somewhere in the system, but not in your user settings or some fancy extensions.

After that you can examine your system further.

Agreeing with that, I would encourage the OP to test at least (on web-sites which are slow, but not those specific websites where he has the extentions for) with another browser. Konqui is installed normaly.

And seld’s advice is also worth trying. Building up piece by piece from a clean config and testing until it goes wrong.

I am using:
Mozilla/5.0 (X11; U; Linux i686; en-GB; rv: Gecko/20100611 SUSE/3.6.4-6.1 Firefox/3.6.4

Why is KDE3 not the official version? it was most certainly offered by the OpenSuse DVD I downloaded and it was marked on default (or was it gnome !?!?!)

Konquerer does not appear to have any of the performance issues mentioned above
I somehow rule out the issue of the Graphics as Firefox ran perfectly fine when used initially.
I’d also rule out the plugin issue as It ran fine with all installed plugins.

top command results
Firefox runs with 4-6% CPU and arround 3.5 mem on idle
and 10-13%cpu with mem still around 3.5 when loading utterly slow

All websites are running slow, mostly on initial loading of pages
Konqueror does not have any of these issues

Even loading a page on the local Tomcat server
which only says “Hello” takes ages…

I indeed see some KDE 3 packages in the 11.2 OSS repos. I just started the 11.2 install DVD to be sure. It offers
O Other
where Gnome is the first and KDE the ticked one (the default). And that definitely installs KDE 4. (The Other button has BTW no KDE 3 to be complete). Thus I do not understand how you get a KDE3 on a 11.2 install without doing special things.

Also the FF in the 11.2 repos is 3.5.9 and not 3.6.4.

This might all have nothing to do with your problem, but not telling it is not very much helping your helpers.

The fact that other browsers have no problems brings me to the conclusion that this is not about the graphics card (driver).

May be you could revert to the OSS version 3.5.9 to see if the problem persists.

Oh sorry,
I got confused with 3 and 4.3, of course I am running KDE 4.3
I have been running this firefox version from the beginning on
as it was one of the first things I did when I set up the system.
The problem first appeared when I set up the Samba server,
I think in the at around same time there was some automatic xorg update
or so…
So maybe it got something to do with that,
but I have stopped the Samba service and it didn’t change anything.

Ok I’ve been a good child and did everything you said,
I downgraded to the OpenSuse supported version and Killed all add-ons.

Didn’t change a thing.

so anyone still any suggestions?
Or do I simply have to hope that the problem goes away with 11.3?