xvidcap sound recording

actually i’ve sound somehow with pulseaudio and alsa-pulseplugin on 11.2.
now how can i get sound recorded with xvidcap?

on openSUSE-11.2 with KDE-4.3.5 it “just worked” for me. But openSUSE KDE4 has pulse disabled by default.

What you could do as a work around, until you sort this, is record audio at the same time as xvidcap is capturing video via a separate application such as:

arecord -vv -fdat an-aribtrary-name.wav

and then combine the xvidcap video with the arecord audio using your application of choice (I have used kdenlive - but thats a kde application]

no luck also audacity cannot open mp4 directly
i tried also:
michael@linux-os4n:~/Dokumente> rec -d /dev/dsp test.wav
rec FAIL formats: can’t determine type of file `/dev/dsp’

Sound needs to be improved for the next suse…>:(

Frankly, I suspect something is misconfigured on your PC. I say that because this works on 5 different PCs I have … and they are all different. Can you record with:

arecord -vv -fdat an-aribtrary-name.wav

should audacity be even opening an mp4? Is that not also a video file container? http://en.wikipedia.org/wiki/MPEG-4_Part_14

no error msg. only a crackling at the beginning and end.

my pc…it took several hours to set up sound in 11.2 >:(
now im happy to have everywhere sound. intel card through alsa-pulseplugin…a joke really…

ok so how could i convert mp4 to wav for audacity?

You need to sort this BEFORE you do anything else. Please again try:

arecord -vv -fdat an-aribtrary-name.wav

and configure your mixer EXACTLY how how thing it should be setup for your mic.

And then with PC connected to internet, as a regular user, run the diagnostic script:


and select the SHARE/UPLOAD option. That will give you a URL. Please post the URL here. Do NOT POST the output !! Just post the URL.

I’m glad to read you succeeded here finally, but several hours is in my view a silly amount of time. Do NOT do that again. Do NOT. Instead simply post for help. I have better things to do than waste several hours on a problem , and I am sure you do also. Spinning one’s wheels like that needless is the sort of time waster that gives Linux a bad name. Simply ask for help. That is what all my Mac friends, and MS-Windows friends do. … and so should Linux users.

Its not a joke.

If pulse is giving you a problem, then you can disable it. One way is:

setup-pulseaudio --disable

and to re-enable:

setup-pulseaudio --enable

Pulse is intended to address a number of deficiencies with Linux sound.

This is premature. To go about this logically, you need to fix your capability to record first. Get the basics established before wasting time on more advanced aspects.

I am VERY suspicious of a configuration problem. Please also post here the output of:

zypper lr -d

ok the output of the script is here:

and no more sound config >:(

I downloaded flv and tried:
ffmpeg -i test-0000.flv -sameq out.wav

no more ffmpeg?

Your mixer is CLEARLY setup up WRONG to record. I asked you to set it up for recording BEFORE running the script. >:(

Look at these settings:

!!Amixer output

!!-------Mixer controls for card 0 [Intel]
Card hw:0 ‘Intel’/‘HDA Intel at 0xf9ff8000 irq 22’
Mixer name : ‘Realtek ALC883’
Simple mixer control ‘Front Mic’,0
Capabilities: pvolume pswitch
Front Left: Playback 29 [94%] [9.00dB] [off]
Front Right: Playback 29 [94%] [9.00dB] [off]
Simple mixer control ‘Front Mic Boost’,0
Capabilities: volume
Front Left: 3 [100%]
Front Right: 3 [100%]
Simple mixer control ‘Mic’,0
Capabilities: pvolume pswitch
Front Left: Playback 0 [0%] -34.50dB] [off]
Front Right: Playback 0 [0%] -34.50dB] [off]
Simple mixer control ‘Mic Boost’,0
Capabilities: volume
Front Left: 0 [0%]
Front Right: 0 [0%]
Simple mixer control ‘Capture’,0
Capabilities: cvolume cswitch
Front Left: Capture 31 [100%] [34.50dB] [on]
Front Right: Capture 31 [100%] [34.50dB] [on]
Simple mixer control ‘Capture’,1
Capabilities: cvolume cswitch
Front Left: Capture 0 [0%] -12.00dB] [on]
Front Right: Capture 0 [0%] -12.00dB] [on]
Simple mixer control ‘Input Source’,0
Items: ‘Mic’ ‘Front Mic’ ‘Line’
Item0: ‘Mic’
Simple mixer control ‘Input Source’,1
Items: ‘Mic’ ‘Front Mic’ ‘Line’
Item0: ‘Mic’

!!-------Mixer controls for card 1 [U0x46d0x994]

Card hw:1 ‘U0x46d0x994’/'USB Device 0x46d:0x994 at usb-0000:00:1d.7-6, high speed’
Mixer name : ‘USB Mixer’
Simple mixer control ‘Mic’,0
Capabilities: cvolume cvolume-joined cswitch cswitch-joined
Mono: Capture 3584 [100%] [19.00dB] [off]

You have two mic devices (a USB and a “jack”). Which one are you attempting to use?

Wrt the “jack”, you have “mic” and “front mic”. Which one are you attempting to use?

Your mixer has 0% capture in some places and the mic OFF in other places.

That is GUARANTEED to ensure you record no audio.

Again, I asked you to set it up for recording BEFORE running the script. >:( You either tried and failed, or you forgot to do that!

What does that mean. I can make NO sense of that statement. Please, I can’t see your PC. I can’t hear your PC. You need to be more clear.

I understand this is frustrating for you, but such cryptic statements make my efforts to help you near impossible.

… and … what do you mean by that ? “no more ffmpeg” ?

Did you check to see if ffmpeg is installed?

What is the output of

rpm -qa '*ffmpeg*'

Also, the command

ffmpeg -i test-0000.flv -sameq out.wav

looks wrong to me. What are you trying to do?

also, … what is output of:

zypper lr -d

… I asked you before to provide that. Did you read my previous post?

michael@linux-os4n:~/Dokumente> mixer
If ‘mixer’ is not a typo you can use command-not-found to lookup the package tha
t contains it, like this:
cnf mixer
michael@linux-os4n:~/Dokumente> kmix
michael@linux-os4n:~/Dokumente> rpm -qa ‘ffmpeg
michael@linux-os4n:~/Dokumente> zypper lr -d

| Alias | Name

| Aktiviert | Aktualisieren | Priorität | Typ | URI
| Dienst
1 | Packman Repository | Packman Repository
| Nein | Nein | 99 | rpm-md | http://packman.mirrors.skynet
.be/pub/packman/suse/11.2 |
2 | games | games
| Ja | Ja | 99 | rpm-md | Index of /
repositories/games/openSUSE_11.2/ |
3 | google-chrome | google-chrome
| Nein | Nein | 99 | rpm-md | http://dl.google.com/linux/rp
m/stable/i386 |
4 | home:dsbhayangkara | home:dsbhayangkara
| Ja | Ja | 99 | rpm-md | Index of /
repositories/home:/dsbhayangkara/openSUSE_11.2/ |
5 | home:gbvalor | home:gbvalor
| Ja | Ja | 99 | rpm-md | Index of /
repositories/home:/gbvalor/openSUSE_11.2/ |
6 | http-download.opensuse.org-d331bd65 | Aktualisierungen für openSUSE 11.2-0
| Ja | Ja | 99 | rpm-md | Index of /
update/11.2/ |
7 | nvidia | nvidia
| Ja | Ja | 99 | rpm-md | http://download.nvidia.com/op
ensuse/11.2 |
8 | openSUSE 11.2-0 | openSUSE 11.2-0
| Ja | Nein | 99 | yast2 | cd:///
9 | repo-debug | openSUSE-11.2-Debug
| Nein | Ja | 99 | NONE | Index of /
debug/distribution/11.2/repo/oss/ |
10 | repo-non-oss | openSUSE-11.2-Non-Oss
| Ja | Ja | 99 | yast2 | Index of /
distribution/11.2/repo/non-oss/ |
11 | repo-oss | openSUSE-11.2-Oss
| Ja | Ja | 99 | yast2 | Index of /
distribution/11.2/repo/oss/ |
12 | repo-source | openSUSE-11.2-Source
| Nein | Ja | 99 | NONE | Index of /
source/distribution/11.2/repo/oss/ |
michael@linux-os4n:~/Dokumente> amixer
Simple mixer control ‘Master’,0

i use kmix? there all is on max. anyway i wanted to record direct from xvidcap without mic? which mixer should i use?

This is a disaster waiting to happen. … assuming it has not already happened.

Delete repository #2, 3, 4, 5, and 7. Disable repository #8 (your cd). You should reduce your enabled repositories to ONLY the following OSS, Non-OSS, Update (which are the 3 official Novell/SuSE-GmbH repositories) and only 1 more: Packman, which is the largest 3rd party repository. Only those 4. No others. None. Not ONE. JUST THOSE 4: OSS, Non-OSS, Update, and packman.

If you MUST obtain an application off of a 5th repository, add the repository, install the application, and then disable or remove the 5th repository. If you do not follow that advice, as a user with your knowledge level your system will gradually go non-functional in some areas and may become unstable. So stick with those 4 until you learn more.

You should install ffmpeg and libffmpeg0 and its dependencies.

With PC connected to the internet type:

su -c 'zypper install libffmpeg0 ffmpeg'

and enter root password when prompted. This will install libffmpeg0 and ffmpeg and their dependencies provide a bunch of codecs that you absolutely NEED! They should be installed from the Packman repository which is your repository #1.

Thats up to you.

Last I looked at your settings most things were muted. So I confess I don’t believe that statement about all on max.

i know i already disabled updater ****