xv doesn't work

I am a ubuntu user that trying get opensuse 11 running on my msi wind laptop. Everything looks pretty well except I got stuck with video playback.

With the one-click installation, I got codes/lib packages from mixed repositories: videoLan and Packman. I have replaced the packages from videoLan with the ones from Packman but video playback still doesn’t work properly.

I can use only x11 as video output for my smplayer; as soon as I switch to xv driver, the screen just went blue.


I tried other media player such as vlc but same problem.

Try starting smplayer and vlc in a console will probably show errors that you can post here

smplayer doesn’t show any information on the log so I ran mplayer on the console.

shawn@BlackPearl:/media/disk/movie> smplayer  Fearless.avi 
This is SMPlayer v. 0.6.2 (SVN r1661) running on Linux
shawn@BlackPearl:/media/disk/movie> mplayer -vo xv  Fearless.avi 
MPlayer 1.0rc2-openSUSE Linux 11.0 (i686)-Packman-4.3 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Atom(TM) CPU N270   @ 1.60GHz (Family: 6, Model: 28, Stepping: 2)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing Fearless.avi.
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
VIDEO:  [DX50]  672x368  24bpp  25.000 fps  852.0 kbps (104.0 kbyte/s)
Clip info:
 Software: VirtualDubMod (build 2066/release)
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec:  afm: mp3lib (mp3lib MPEG layer-2, layer-3)
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
VDec: vo config request - 672 x 368 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.83:1 - prescaling to correct movie aspect.
VO: [xv] 672x368 => 672x368 Planar YV12 
A:  11.7 V:  11.7 A-V:  0.000 ct:  0.001 293/293 11%  1%  1.5% 7 0 
Exiting... (Quit)

What happens if you disable ‘special desktop effects’ ? (by “special desktop effects” I mean ‘the cube’ / ‘3D’ ). … Also, what graphic hardware do you have (as some Intel hardware devices had this problem with different drivers).

‘Desktop effect’ was disabled before I ran mplayer/smplayer.

Here is my video card

shawn@BlackPearl:/media/disk/movie> /sbin/lspci |grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)

In openSUSE-10.3, this is in the release note:

Older Intel Graphics Chips

Older Intel graphics chips are supported by two drivers ( “i810” and “intel” ). The intel driver is the default on openSUSE 10.3 due to the high demand for features like native mode setting (no longer VESA BIOS based) and RANDR 1.2 support.

When updating to openSUSE 10.3, the i810 driver is not exchanged with the intel driver. Use “sax2 -r” to switch to the intel driver.

The intel driver is still not as stable as i810; use “sax2 -r -m 0=i810” to switch back to i810, if you encounter problems that did not occur previously with the i810 driver. In those cases, consider to open a bug report against the intel driver.
I’ve read of openSUSE-11.0 users having similar problems, although I do not know if the graphic driver situation is exactly the same.

In 10.3 users who wanted 3D/desktop effects needed the superior performance that came from the “intel” driver. But it had problems with video (like you noted). Users who wanted more stability, and the “xv” driver to work, would resort to the i810 driver.

Not sure if that helps, but its possible that 11.0 suffers from something similar to 10.3.

I tried to switch to i810 but X didn’t come up.