Xterm redraw lag

After upgrading from Leap 15.3 to 15.4, the xterm fails to print some lines of output until a key is pressed, or prints with substantial delay. It happens often enough to be annoying, and seldom enough to reproduce. The last time it was while running gdisk - quite a bit of fun.

I’ve noticed the following in /var/log/messages:

2023-08-04T14:17:52.969022+02:00 myhost /usr/lib/gdm/gdm-x-session[2237]: (EE) event6  - Metadot - Das Keyboard Das Keyboard: client bug: event processing lagging behind by 18ms, your system is too slow

I’ve got an AMD Ryzen 9 3900XT 12-Core Processor, GeForce RTX 2070 Super GPU.

CPU utilization at the moment is minimal. Memory also seem to be abundant:

~>free -h
              total        used        free      shared  buff/cache   available
Mem:           62Gi       3,6Gi        56Gi        39Mi       3,7Gi        59Gi
Swap:          62Gi          0B        62Gi

Any idea what to look for? What can be done to fix the issue?
Thanks in advance!

I get that message from time to time. It seems to come from “lininput”, and you can probably ignore it.

Is there any possibility that this is the same problem as reported in Bug 1200779?

It’s similar, but not quite.

  • “Reproducible: Always” does not apply. For instance, I’ve tried to reproduce the bug that you mentioned, but worked fine for me despite having a rather elaborate .vimrc.
  • On Leap 15.3 it worked fine.

I’ve tried to run top and stop it via Ctrl+C. This reproduces the problem more frequently. I’ve also noticed, that not any key brings xterm back to normal, but only those that add something to the picture: a letter, arrow up (but not arrow left or right).