XSession: login for <USER> is disabled

Hi,

I am new to Linux overall and I am running OpenSuse 13.1 with KDE as a workstation and today when I tried to login with my default user (not root) I keep receiving this message on the title of the post.

Right now I am logged in as root to post this message, but I wouldn’t want to keep working as it is. Can anyone help me with this issue please? I’ve looked around the forum and the only related post is regarding the same issue but logging in as root, which is not my case.

Thanks.

Do you have an LDAP or Windows Network (Samba Acive Directory Authentication) that you login to normally with your user account?

No I don’t. I log in directly on the local machine.

I was looking around Yast’s user configuration and I just realized the Login Shell for the user in question is /bin/false. Shouldn’t it be /bin/bash?

It most certainly should be!

That would certainly prevent from logging :slight_smile:

Yeap, changing that solved the problem, but now I am intrigued about how the hell that was changed to /bin/false.

Anyone else have access maybe someone played a trick