XServer won't start


I’m quite new to Linux, so please be patient with me. :slight_smile:
Today I’ve updated from SUSE 11.0 to 11.1 and now I can’t use the graphic interface unless I login in Failsafe mode. I’ve had this problem already once before, after I installed a driver for my ATI Radeon HD 3600, but then I didn’t have the time to really deal with it so I simply reinstalled the whole openSUSE. After that, in was working again.
But now I’d like to know what I’ve done wrong and how I can fix this so it won’t happen a 3rd time. :wink:
So, when I logged in as root in the console and typed “startx”, everything was normal at first, but then this came:

(EE) Failed to load module “type1” (module does not exist, 0)
(WW) Module ABI major version (0) doesn’t match the server’s version (1)
dlopen /usr/lib/xorg/modules//drivers/fglrx_drv_so: undefined symbol: miZeroLineScreenIndex
(EE) Failed to load /usr/lib/xorg/modules//drivers/fglrx_drv_so
(EE) Failed to load module “fglrx” (loader failed, 7)
(EE) No drivers available

I understand it has something to do with a driver, probably the one I installed for my ATI grafic card. But I don’t really understand what I have to do to get the Xserver working again.
So, I’d be really grateful for some help (in words a non-expert can understand, please) :slight_smile:

Login as user at the console then become su and do

sax2 -r -m 0=vesa

(that’s a zero=vesa)

then do


This will give you a basic vesa driver. But that’s the same as Failsafe is giving you. So you could just login from failsafe and look at installing the ATI driver again
ATI - openSUSE

Ok, the 1st one worked. I’ll try installing the latest ATI drivers too, though, but only after reading some more information on them. :slight_smile:
Thank you very much!

somehow, I can’t access the graphical interface AGAIN. :\ This time, I have a suspicion that it has something to do with how I upgraded Firefox from 3.5.4 to 3.5.5 - while it was installing through YaST, I saw in the protocolls that it did something with the fglrx driver. I didn’t look closer though, and after that everything was fine. Only after I switched my computer off and then wanted to switch in on again later, it didn’t work: After the loading image the screen suddenly became really weird - one half of it was pink and the other one black, and on the pink one there were listed the processes you normally only see when logging in in Failsafe mode.
I’ve already tried logging in in Failsafe mode, the command given in the post above, also “rcxdm restart” and “startx”, but nothing works.
Could you please help me again?

You tried the vesa switch above?

Yeah, after that it goes like this:

SaX: no X-Server running
SaX: will start own server if needed
SPP: prepare device [0] profile: FireGL.addon

And when I try to “startx”, it says that it has to be key -> [sequence], variable definition or #command.

Just to confirm this is 11.1

I went here to check the official driver:
ATI Catalyst™ Proprietary Display Driver

That is the one for you, unless you are _64 bit?? Then back track to get that. Download also the Installer Instructions and from Page 4 at the Sub Heading: Automatic Driver Installation

If you can’t get to your current desktop you can put the file in your /home/username with a live cd like Parted magic

Ok, I’ll try that, hopefully it’ll work. Thanks.:slight_smile: