Xserver dies when some programs are launched

Hello linux gurus,

I really need your advice (:

Background information:

OpenSUSE 11.0, upgraded from 10.3 using zypper dist-upgrade.
Plain KDE 3.5.9, composite extensions are disabled.
Onboard intel videocard, drivers are installed properly.
IBM Thinkpad r61.
Problem occurs only in OpenSUSE 11.0

**Problem: **
whenever some applications are launched, X dies and brings the whole system down (ctrl-alt-F[1-9] & ctrl-alt-backspace are not working).
When the crash occurs, system starts working slower, then screen goes black for a second, then the image appears again, and it freezes (even cursor is not moving). It tries to read something from hard disk for a first few moments.

That’s what logs are saying:

(WW) xf86AcquireGART: AGPIOC_ACQUIRE failed (Device or resource busy)
(EE) GARTInit: AGPIOC_INFO failed (Operation not permitted)
(WW) intel(0): /dev/agpgart is either not available, or no memory is available
for allocation. Using pre-allocated memory only.
(==) intel(0): VideoRam: 7676 KB
(II) intel(0): Attempting memory allocation with tiled buffers

(few repeated lines)

(II) intel(0): Allocating 255 scanlines for pixmap cache
((EE) intel(0): Failed to allocate framebuffer. Is your VideoRAM set too low?
(EE) intel(0): Couldn’t allocate video memory

Fatal server error:
AddScreen/ScreenInit failed for driver 0

I suspect it has something to do with a new kernel, which was shipped with OpenSUSE. I’ve tried reinstalling it, but it didn’t work.

Usually the crash happens when graphically-intensive applications are started. But it’s quite irregular. For example, when I start google-earth from offline, it crashes. When i start it, and i am online, it does not (presumably it tries to load the whole cache into the memory?)
reproducibility is 100%
Opengl gears are working. Warcraft III under wine crashes. Compiz-fusion, if I turn it on, is working.

I was looking through BIOS settings to find the option which says how much memory is allocated to videocard, but haven’t found it. However, I found option LinearAlloc in xorg.conf.
I’ve tried increasing it to 128000 from 32000 but it didn’t change anything.


If I won’t be able to fix the problem in the nearest future, I’ll try reinstalling from scratch, and/or downgrading the kernel. I really don’t want to do this, though.

Can you please suggest any ideas how can I fix that problem?

anyone?.. google does not give any relevant results for this error message :frowning:

Update: problem does not occur in KDE4. Weird…