xscreensaver support for KDE missing: kxsrun and kxsconfig no longer available

Previously KDE 4 was able to support xscreensaver screen savers, however as of 11.3 it appears that xscreensaver support within KDE has been removed. kxsrun and ksxconfig were apps that wrapped around an xscreensaver app for native KDE support, however I can’t find them in any 11.3 repositories.

Were these removed intentionally?

It appears that KDE themselves removed them from their packages - can anyone confirm this?

Okay - I officially call shenanigans.

I just rebuilt kdeartwork4-screensaver version 4.4.4 revision 1.4 from Index of /source/distribution/11.3/repo/oss/suse/src . Voila - kxsrun and kxsconfig are there. And they work.

For those interested - I had to perform:
sudo rpmbuild --rebuild kdeartwork4-4.4.4-1.4.src.rpm

And then install the kdeartwork4 packages rebuilt inside of /usr/src/packages/RPMS

Still not sure if this is KDE’s tomfoolery or if this is openSuSE’s, but needs to be fixed. A league of skytentacles cry out to be heard.

Hi there. Thanks for looking into this. Sorry - I’m a bit slow as to what you’re doing here.

I downloaded kdeartwork4-4.4.4-1.4.src.rpm, then ran ‘sudo rpmbuild --rebuild kdeartwork4-4.4.4-1.4.src.rpm’ then it says:

Installing kdeartwork4-4.4.4-1.4.src.rpm
error: unpacking of archive failed on file /usr/src/packages/SOURCES/kdeartwork-4.4.4.tar.bz2;4c425638: cpio: read
error: kdeartwork4-4.4.4-1.4.src.rpm cannot be installed

What am I doing wrong here? Thanks.

Don’t use sudo for building anything!! you build/rebuild configure and
make as your user. Doing that may have mucked up the permissions
on /usr/src/packages. The only time you need to use sudo or be root
user is to install. Can you check your permissions they should be;


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.3 (i586) Kernel 2.6.34-12-desktop
up 3:27, 2 users, load average: 0.34, 0.40, 0.31
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

Thanks for your help. The permissions are:

drwxr-xr-x 13 root root 4.0K Jul 6 07:49 usr/
drwxr-xr-x 6 root root 4.0K Jul 18 00:51 src/
drwxr-xr-x 8 root root 4.0K Jul 6 07:51 packages/
drwxrwxrwt 2 root root 4.0K Jul 18 04:13 SOURCES/

and SOURCES contains the following three files:

-rw-r–r-- 1 root root 206 May 28 14:12 4_4_BRANCH.diff
-rw-r–r-- 1 guest users 206 Jul 18 04:13 4_4_BRANCH.diff;4c42633b
-rw-r–r-- 1 root root 81 Jan 10 2009 baselibs.conf

There will be files in SOURCES, SPECS as well as BUILD possibly. You
need to go in there and remove the files manually (as root user). Then
try the command again as your user.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.3 (i586) Kernel 2.6.34-12-desktop
up 5:16, 2 users, load average: 0.06, 0.05, 0.04
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

I would recommend running sudo for the rpmbuild process. This should not muck up permissions within /usr/src/packages and should not result in cpio errors.

It appears that either the download is corrupted or there is some issue with the filesystem itself. I do agree that clearing out the /usr/src/packages/BUILD and /usr/src/packages/SOURCES directories should be cleared out and the .src.rpm file re-downloaded just to be sure.

Let me know what architecture you’re on (i586 or x86_64) - I might be able to build the binary packages and post them.

Hi there - thanks again for this. I’ve now managed to build the rpms (by deleting various things and trying again - it just worked).

OK now I did exactly what you said above and I installed the two resulting rpms in /usr/src/packages with:

rpm -e kdeartwork4-4.4.4-1.4.x86_64
rpm -i kdeartwork4-4.4.4-1.4.x86_64.rpm
rpm -e kdeartwork4-screensaver-4.4.4-1.4.x86_64
rpm -i kdeartwork4-screensaver-4.4.4-1.4.x86_64

This appeared to work fine. Now when I look at the list of screensavers in “System Settings -> Desktop -> Screensavers” it’s exactly the same as before (certainly no ‘Molecule’). How do I check whether kxsrun etc. are now working, and how can I refresh the list of screensavers?

Here are the steps that I took. I also installed Really Slick Screensavers along with the XScreenSavers:
[li]Use YaST2 to install xscreensaver, xscreensaver-data and xscreensaver-data-extra
[/li][li]Download the kdeartwork4 source RPM from downloads.opensuse.org
[/li][li]Rebuild the kdeartwork4 package using: sudo rpmbuild --rebuild kdeartwork4-4.4.4-1.4.src.rpm
[/li][li]Re-install the kdeartwork4-screensaver package using: sudo rpm -Uvh --force kdeartwork4-screensaver-4.4.4-1.4.x86_64.rpm
[/li][li]Download Tugrul Galatali’s Linux port of RSS at Really Slick Screensavers GLX Port
[/li][li]Extract rss-glx, then run:
[li]./configure --prefix=/usr --bindir=/usr/lib64/xscreensaver
[/li][li]sudo make install
[li]Download the updated KDE screensaver service entries from kde-look.org at KDE4 Entries for RSS & XScreenSaver KDE-Look.org
[/li][li]Extract the archive xscreensaver.tar.bz2, it should create an xscreensaver directory
[/li][li]Copy the service entries with: sudo cp ~/Downloads/xscreensaver/*.desktop /usr/share/kde4/services/ScreenSavers/
[/li][li]Check and make sure the screensavers are installed as expected using xscreensaver-demo
[/li][li]killall xscreensaver to clean up from the previous step
[/li][li]Take a look at your KDE desktop settings now. There should be extra entries in there for OpenGL screensavers and Really Slick Screensavers; try out Pixel City

Let me know if that doesn’t work for you!

There, that works! Thanks very much for your help - it is greatly appreciated!

Lots of beautiful screensavers there - what a pity they’re not part of the standard distribution… :slight_smile:

Hi - actually one more thing. It turns out that my screens go black a few minutes after the screen saver turns on. Any idea what would cause it to do that? I have all possible power management turned off.

Oh believe me it will at some point, there is no reason what
so ever to do this.

But at the end of the day, it’s your system and your free to do
whatever you like, but please DON’T recommend it to other users :slight_smile:

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 0:37, 2 users, load average: 1.07, 1.04, 0.85
GPU GeForce 8600 GTS Silent - Driver Version: 256.35

Do you have the xscreensaver daemon running? If so, kill it off using:

killall xscreensaver

Otherwise not too sure.