XSCREENSAVER no longer functional

Greetings All,

A recent update to SUSE 15.3 seems to have changed something with xscreensaver.

When I try to start this app I get the following message:



>xscreensaver
          
xscreensaver-auth: 15:47:42: OOM: /proc/18626/oom_score_adj: Permission denied
xscreensaver-auth: 15:47:42:   To prevent the kernel from randomly unlocking
xscreensaver-auth: 15:47:42:   your screen via the out-of-memory killer,
xscreensaver-auth: 15:47:42:   "xscreensaver-auth" must be setuid root.
xscreensaver-systemd: 15:47:42: connection failed: "org.freedesktop.ScreenSaver" in use by pid 4937 (/usr/bin/ksmserver)
xscreensaver: 15:47:42: pid 18628: xscreensaver-systemd exited unexpectedly with status 1



Before the update(s), this worked perfectly.
Something new has been added…

I have tried:
a) removing (and recreating) the ~/.xscreensaver file
b) uninstalling and reinstalling xscreensaver

Any ideas on the magic spell to return xscreensaver to usability?

Thanx.

Richard Rosa

Well I found 1/2 of the solution:
chmod +s /usr/lib/xscreensaver/xscreensaver-auth
Fixed most of the error message.

However, GLSLIDESHOW is still not functional.
when running xscreensaver-demo i get these messages


X error in glslideshow:
glslideshow:   Failed request: 158
glslideshow:   Major opcode:   152 ()
glslideshow:   Resource id:    0x0
glslideshow:   Serial number:  116 / 116

This is the ONLY one that I am interested in…

Richard Rosa

Problem solved!

It appears that xscreenserver v 6.02 is NOT compatible with something in SUSE 15.3.
Downgraded xscreenserver to version 5.44 and all is well again.

Thanx to all that responded…

Richard Rosa

Well, you solved it yourself without much response at all :).

When I am correct that version 6.02 is the curectnt up-to-date version belonging to 15.3 and you had to revert to an earlier version, then that is clearly a bug.

Please file a bug report, else nothing will be done to repair this. And I assume you understand you can not go on using the old version forever.

Information is here: https://en.opensuse.org/openSUSE:Submitting_bug_reports

And it is here: https://bugzilla.opensuse.org/index.cgi

Checking with Yast Software Management, version 5.44 is what is in the standard repos.

I think the OP has installed 6.02 from somewhere else – perhaps a development repo – but has failed to tell us that.

Of course, I tried to check “xscreensaver-auth” but it is not anywhere on my 15.3 system.

Please, folk, when you are having problems with an application that does not come from the standard repos, at least tell us what you actually installed. Guessing is not a good way of helping people.

Oh, I should have checked that.:’(.

If you trust that people give you correct information, you will always regret it. :disapointed:

With the offending version:

xscreensaver-command -exit
xscreensaver -v -log log.txt

to obtain a log file, then raise a bug report.

Downgrading the package is not a “solution”, just a temporary fix…

Now the xscreensaver version is 6.03 and it doesn’t work on my Leap 15.4 and on an old 32bit netbook with Tumbleweed.
I’m forced to use older versions of xscreensaver, now it’s 5.44 on Leap 15.4 and 5.29 on Tumbleweed. They work without any problem.
It is strange that the problem has remained so far, despite the bugreports.

This is a 15.3 thread!

Please start a new thread with the correct prefix. Do not confuse people.

ok, you’re right, thanks for the correction.

Closing this thread.