xSANE again

Hi all,

I recently asked advice about how to get my AGFA Snapscan e42 going. I received a lot of advice ad indeed it worked, one day.

Since then I get the following error, while using the Scanner configuration in YAST :

[snapscan]Cannot open firmware file /usr/share/sane/snapscan/your-firmware.bin
[snapscan]Edit the firmware file entry in snapscan.conf
scanimage : open of device snapscan:libusb:002:003 failed : Invalid argument

It seems clearly that YAST can detect the scanner, but can’t get it going.

Any help will be greatly appreciated,


You need to copy the file snape42.bin (will be available on the windoze driver disk that came with the scanner) to the directory /usr/share/sane/snapscan/
Then, edit the file /etc/sane.d/snapscan.conf and replace the file name your-firmwarefile.bin with snape42.bin (in the line shown below).

firmware /usr/share/sane/snapscan/your-firmwarefile.bin

And it works perfectly fine.
Thank you very much.

I do not understand though, how, from time to time I could scan and then I could again not scan. Agfa mystery, I suppose.


Good to hear that it worked.

We will try to figure it out if it stops working again.