Xrdp died after update


I just recently setup a OpenSUSE 11.3 server with Xrdp which I got from the 11.1 tutorial. Everything had been working great until yesterday I let the system run a update and now whenever I try to login I get login failed. When I look in xrdp-sesman.log file it says X server died. I’ve searched around for this problem and it seems there is some talk about it from a few years back but nothing as of recent and nothing that has worked so far. I’m kinda at a loss with this and really would like to get it up and running again. Any help will be greatly appreciated.


If it’s a server, I would look at using NX (from nomachine) if you don’t need to look at a users desktop. Have you seen one of our Admin’s web pages;
openSUSE SuSE Linux HOWTOs and Tutorials by Swerdna

Ok never mind I fixed the problem. I edited the xrdp.ini file and changed the lib=libdmx.so to lib=libvnc.so.

Thanks for the info! The FAQ listed for xrdp was the one I used to install and it was working great then the updates killed it. Like I said the fix above solved my problem and actually solved a couple other problems with screen resizing… Woohoo glad I got this figured out.