xrandr issue after latest TW snapshot.

Hi community,

I used to start the steam client on my Optimus laptop following the advice of the Arch Linux wiki:

https://wiki.archlinux.org/index.php/PRIME

(reason: I want to use it with nouveau). However after the latest update steam refuses to start giving the following error:

   ~] λ Running Steam on opensuse 20150630 64-bit 

STEAM_RUNTIME is enabled automatically
/bin/bash: /home/benjamin/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libtinfo.so.5: no version information available (required by /bin/bash)
/bin/bash: /home/benjamin/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libtinfo.so.5: no version information available (required by /lib64/libreadline.so.6)
Installing breakpad exception handler for appid(steam)/version(1433441724)
libGL error: unable to load driver: nouveau_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: nouveau
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

I start this using a small bash-script with the following content:

   ~] λ cat bin/discrete_chip_start.sh  

#!/bin/bash
xrandr --setprovideroffloadsink nouveau;
DRI_PRIME=1 $1

Can anyone help with this?

Cheers

Nobody here that can say anything hwo this might be resolved?

Cheers