XPS M1330, audio from front mic stopped working after upgrad


my sound card was working great - even the webcam mic did work.

yesterday I updated the alsa driver, and now I get no sound from the two front output jacks. All else seems to work, including integrated loudspeakers, plug-mic and sometimes even webcam-mic.

The two front output plugs do not work, though; I cannot link my pc with external loudspeakers or with headphones: in that case I only get some static (at very low volumes).

Sometimes running “alsaconf” as root solves the problem - but then, after a reboot,everything is again as before. The result seems random, though, as running “alsaconf” 95% fo the times does not change anything.

In short: here are my details:
XPSM1330, sound card recognised as snd-hda-intel.

output of alsa troubleshooting script:
tsalsa.txt - nopaste.com (beta)

rpm -qa | grep alsa

uname -a
Linux rodolfo #1 SMP 2008-10-14 22:17:43 +0200 i686 i686 i386 GNU/Linux

rpm -qa | grep pulse

cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

rpm -q libasound2

I tried to change the MODEL option of the card, to no avail. I tried to reinstall the drivers after having upgraded the kernel, to no avail. SOmetimes it works, after tweaking, for apparently no reason; then, on reboot, it starts again with static and no sound (from front plugs: loudspeakers are indeed working).

Any help?

Thanks thanks thanks

ok … partial audio …

Are you using ndiswrapper or madwifi with a wireless connection?

Can you, immediately after restarting, try running in a gnome-terminal or konsole: su -c 'rcalsasound restart’and enter root password when prompted. Test your sound then. Does that work? If so, we can make that permanent upon boot via editing a local boot file.

What model options did you try? The ALSA-Configuration.txt file provides these options for your Laptop’s STAC9228 hardware audio codec:

	  ref		Reference board
	  3stack	D965 3stack
	  5stack	D965 5stack + SPDIF
	  dell-3stack	Dell Dimension E520
	  dell-bios	Fixes with Dell BIOS setup 

Which ones of those did you try? What was the exact syntax to the /etc/modprobe.d/sound file syntax that you used?

If you have no success with the above suggestions, can you provide the output of your dmesg file? You can do that by immediately after a reboot copy and paste into a gnome-terminal or konsole:
dmesg > dmesg.txt && curl -F file=@dmesg.txt nopaste.com/a
and post here the output URL

Good luck.

Thanks OldCpu, that was FAST!

  1. No, I am not running ndiswrapper or any other fancy wireless. I do have wireless through a kernel module, and it works fine without ndiswrapper.

  2. trying “su -c ‘…’” right after reboot won’t help.

  3. models. I tried all of them. The only one with results is 5stack. When using 5stack one of the front output plugs (I have 2) works, the other doesn’t; the one that works, does so simultaneously with pc loudspeakers (I get sound from both loudspk and headphones). This is wierd. Even odder: when I restart alsa deleting the line with the 5stack option (syntax: "options snd-hda-intel model=modelname), the new feature (simultaneous sound) continues to live.

4.basically, restarting alsa changes the performance of the system in an unpredictable way, changing the model does the same, and I do not understand why. Restaritng alsa could yield to no sound, sound just from loudspeakers, concurrent sound from ldspk and one of the two plugs, sometimes (it happened ondce since yesterday morning) to system working as it should.

5.here is the dmesg report:
dmesg.txt - nopaste.com (beta)

  1. couldn’t it be a bug in the new alsa, which is still a RC and not stable?

Thanks for your thorough help

According to the openSUSE hardware compatibility list (HCL) for your laptop, the model setting that should work successfully is “3stack”. Reference: HCL/Laptops/Dell - openSUSE

… Thanks, I note this in the dmesg:

ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/hda_codec.c:3332: autoconfig: line_outs=1 (0xd/0x0/0x0/0x0/0x0)
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/hda_codec.c:3336:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/hda_codec.c:3340:    hp_outs=2 (0xa/0xf/0x0/0x0/0x0)
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/hda_codec.c:3341:    mono: mono_out=0x0
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/hda_codec.c:3349:    inputs: mic=0xc, fmic=0xe, line=0x0, fline=0x0, cd=0x0, aux=0x0
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/../../alsa-kernel/pci/hda/patch_sigmatel.c:2831: dac_nids=3 (0x2/0x5/0x3/0x0/0x0)
input: HDA Digital PCBeep as /class/input/input6


ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/hda_codec.c:3332: autoconfig: line_outs=1 (0xd/0x0/0x0/0x0/0x0)
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/hda_codec.c:3336:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/hda_codec.c:3340:    hp_outs=2 (0xa/0xf/0x0/0x0/0x0)
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/hda_codec.c:3341:    mono: mono_out=0x0
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/hda_codec.c:3349:    inputs: mic=0xc, fmic=0xe, line=0x0, fline=0x0, cd=0x0, aux=0x0
ALSA /usr/src/packages/BUILD/alsa-driver-unstable/pci/hda/../../alsa-kernel/pci/hda/patch_sigmatel.c:2831: dac_nids=3 (0x2/0x5/0x3/0x0/0x0)
input: HDA Digital PCBeep as /class/input/input7 

I suspect the 2nd occurrence was after you manually did something to try to fix your sound.
But other than provide setup parameters, I do not understand if that provides anything useful.

Yes, this could be a problem with alsa wrt your XPS M1330 stac9228. If so, you will need to tell the openSUSE/alsa developers so they know of the problem. I think this Dell is a fairly popular laptop, so hopefully the bug report will get attention reasonably fast.

Hence I recommend you raise a bug report on both opensuse and alsa on the inconsistent behaviour of your stac9228 on an XPS M1330 laptop:

Could you provide to me the syntax you used in the /etc/modprobe.d/sound file (as a quality check) ? Aside from that, I reviewed the material you provided, and I can not provide any further recommendations. Apologies that I can’t help more.

Thanks Oldcpu,

I filed a bug report. It must be something related to alsa: it was working with 1.0.17!! Even the webcam mic! And now, after I checked, I have not even the plug mic working.

Here is the report.

Just a question for you: do you know where I could find the alsa 1.0.17? Maybe downgrading the driver could solve my problem… unfortunately it is no more in multimedia repo.


Ok, solved this problem.

  1. I found the old 1.0.16 drivers on a repo, i.e. here; removed the 1.0.18 driver, filed a bug to alsa (it must be a bug of 1.0.18!!):
    Index of /repositories/home:/pedro_seon:/alsa-intel/openSUSE_10.3

  2. I wiped out the Yast config for the audio, and also /etc/modprobe.d/sound;

  3. rebooted to have my sound fully working, internal and external mic, muting speakers when plugging headphones, etc.

Hope the report on how I did might help someone else.

Try looking on webin for alsa. For example, I get this on webpin in a search for alsa for openSUSE-10.3: Webpin search results for alsa for openSUSE-10.3 … note there are rpms packaged by user j-engel, although I have no idea as to what kernel they were compiled against.

You could always try downloading the alsa tarball from the alsa web site, and build it yourself, using ./configure, make, su, checkinstall. I find checkinstall works for alsa (instead of make install) and it has the added advantage of creating custom home-built rpms that you can remove later.