xpenguins trouble

I start xpenguins and I don’t see any.

xpenguins
Redrawing overwritten desktop icons

And which desktop environment are you using?

Quoting from the included README.SuSE:

Drawing to the correct X window

A number of window managers and desktop environments place a big window
over the root window, which programs such as XPenguins must draw to to be seen.
Of the WMs and DEs that do this, XPenguins works with KDE 2.0 and 2.1,
Nautilus, Enlightenment and a number of simple virtual window managers.
On KDE 2.2.1+ you must enable the Support Programs in Desktop Window option
under Control Center -> Look & Feel -> Desktop. Similarly in CDE you
should set the backdrop of your workspace with the Style Manager to no-backdrop.

You can also use kroot wrapper for calling xpenguins.

Your SuSE team

It’s probably not going to work at all on modern DE’s like KDE4 or GNOME3.

PS: It does work in KDE4 here if I disable desktop effects (compositing) and quit/kill “plasma-desktop”.
But that makes the desktop disappear of course…

I am using kde4. Why does kde draw a big window over the root window? It breaks things like xpenguins, normally all programs avoid breaking other programs, or even causing undesirable behavoir.