XP no longer booting after installing Suse

Don’t know if installing Suse has anything to do with this issue, but basically my XP partition is no longer booting.
I cloned my XP partition across to a new hard drive and then installed Fedora 10 onto it as well. Fedora and XP were able to boot up no problem.
I then installed Suse, putting it bootloader onto the Suse partition. I can choose Suse from the Fedora bootloader, which the redirects me to the Suse loader and boots no problem.
The problem is that when I now choose XP, it can’t seem to boot and I end up with just a grub command line.

My grub.conf for reference is below, but can’t see any problem there.

default=0
timeout=5
splashimage=(hd0,1)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.27.21-170.2.56.fc10.i686)
root (hd0,1)
kernel /vmlinuz-2.6.27.21-170.2.56.fc10.i686 ro root=UUID=d7ea3cc5-1e12-473f-b087-13771593b7d0 rhgb quiet
initrd /initrd-2.6.27.21-170.2.56.fc10.i686.img
title Fedora (2.6.27.5-117.fc10.i686)
root (hd0,1)
kernel /vmlinuz-2.6.27.5-117.fc10.i686 ro root=UUID=d7ea3cc5-1e12-473f-b087-13771593b7d0 rhgb quiet
initrd /initrd-2.6.27.5-117.fc10.i686.img
title SuSE
rootnoverify (hd0,7)
chainloader +1
title Windows XP
rootnoverify (hd0,0)
chainloader +1

Obviously XP is on sda1.

Any suggestions?

Obviously XP is on sda1
No, Suse sometimes changes the partition table. Post output of ‘fdisk -l’ l=small L , to be sure.

Ok,fdisk-l below.

linux-a5hz:~ # fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000a5e1f

Device Boot Start End Blocks Id System
/dev/sda1 32 2708 21503002+ b W95 FAT32
/dev/sda2 1 31 248976 83 Linux
/dev/sda3 * 2709 10781 64846372+ 5 Extended
/dev/sda4 10782 19457 69689970 83 Linux
/dev/sda5 2709 2963 2048256 82 Linux swap / Solaris
/dev/sda6 2964 5527 20595298+ 83 Linux
/dev/sda7 5528 8133 20932663+ 83 Linux
/dev/sda8 8134 10781 21270028+ 83 Linux

And on the original disk, XP was also installed on a FAT32 partition (which BTW is a stupid idea)?

BTW:

/dev/sda1 is not bootable, set the boot flag for sda1, Windows normally wants to reside on a bootable partition.

And on the original disk, XP was also installed on a FAT32 partition (which BTW is a stupid idea)?
I normally install XP on a FAT32 system.

/dev/sda1 is not bootable, set the boot flag for sda1, Windows normally wants to reside on a bootable partition.
To run, XP does not need to be on a active partition (only when installing).

Grub stage1 is installed on the extended partition sda3, that is no problem. Sda3 must be the active partition, unless grub stage1 is also install into the MBR.

Did you install XP on a FAT32 partition ? Suse might have change it from NTFS. Can you mount and see the data on XP partition ,sda1 ?

If you think sda1 should be NTFS or partition can not be mounted, do the code below.

from a root terminal;

dd if=sda1 of=sda1vbr count=1 bs=512

xxd sda1vbr

post output

FAT32 or NTFS: Making the Choice

That’s a bit rugged. We’re a community here.

And on the original disk, XP was also installed on a FAT32 partition (which BTW is a stupid idea)?

Thankyou for your opinion. I installed onto FAT32 a couple of years ago when ntfs support in Linux was limited.

Can you mount and see the data on XP partition ,sda1 ?

Yes, no problem. Can see all the files as normal. I actually set up my Thunderbird to store emails in this partition.

Grub is also in the MBR and sda2 which is /boot for Fedora. When I choose Suse, it then loads the Suse version of Grub which is on sda8 (I think). Have tried to put the chainloader in for XP within the Suse loader, but I still get the same error.

Now it says when choosing XP, GRUB Geom Error, which seems to be some prob with BIOS etc, but I think this is a red herring.

I must re-iterate that it was working before when it only had Fedora (and XP) on. This issue came about after I installed Suse. Both Fedora and Suse work absolutely fine…just XP is no longer bootable.

I think settting the ‘Boot flag’ on the XP partition is the next step as suggested. Will report back later today when home.

Thanks for the help :wink:

I would make things easier and add a real entry for openSUSE to your Fedora menu.lst instead of a chainloading command.

I always install GRUB to the MBR, in order to avoid such strange trouble and because openSUSE offers you an easy way of restoring the former MBR if you have problems.

You could have even chosen to install no bootloader at all when installing openSUSE and add the respective entry to the Fedora menu.lst.

Now it says when choosing XP, GRUB Geom Error,

More fore the record, also this entry is quite old, but perhaps worth reading:

SDB:The Boot Process Hangs with the Message GRUB Geom Error - openSUSE

I think settting the ‘Boot flag’ on the XP partition is the next step as suggested. Will report back later today when home.

There should be even another way without touching the partition table, GRUB offers the parameter


makeactive

which should be enough for making the XP partition bootable when chosen in Grub.

I would make things easier and add a real entry for openSUSE to your Fedora menu.lst instead of a chainloading command.
I always install GRUB to the MBR, in order to avoid such strange trouble and because openSUSE offers you an easy way of restoring the former MBR if you have problems.
You could have even chosen to install no bootloader at all when installing openSUSE and add the respective entry to the Fedora menu.lst.

True, there’s various ways to do this. For now it works though.

There should be even another way without touching the partition table, GRUB offers the parameter

Code:

makeactive

which should be enough for making the XP partition bootable when chosen in Grub.

Should this command be put in the menu.lst file (or grub.conf) such that

title Windows XP
rootnoverify (hd0,0)
**makeactive**
chainloader +1 

Cheers
:wink:

Exactly as you typed.

A comprehensive manual can be found here:

GNU GRUB Manual 0.97

Ok, tried to put the makeactive command in and it still did not work.

So I just decided to re-clone my XP partition that I had on an external drive, using Clonezilla and bingo…it now works.

It still doesn’t answer the question as to why this happened and how to fix it…but hey ho.

Thanks everyone for advice.

:slight_smile: