XP deletes bootloader


I installed openSuse 11.1 on my PC and later I installed XP (first partioned with gparted).

I repaired the system with the openSuse DVD to get the bootloader again and it worked, but if I boot with XP, Windows deletes the bootloader.
So if I start the computer again it boots from Windows without asking.
But if I boot from openSuse the bootloader still exists.

You really need to provide a more comprehensive account of what you are doing, together with details of your system.

What you describe is quite strange, and I suspect there is more to this than is apparent from your brief account.

look: I have openSuse 11.1 KDE 4.2 on my PC.
I installed XP, which deleted the bootloader.
I went on with the openSuse DVD and repaired the system (so I got the bootloader back).
After that I started and the bootloader was there.
If I boot with openSuse everything is ok, but if I boot XP the bootloader is after a restart gone.

take a look at these sites:

GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.
Recover grub bootloader with Vista, Xp and Linux (new) « /home
triple boot/install order for xp/opensuse/leapord osx - [H]ard|Forum
installing openSUSE 10.2 on a dual booting Vista/XP system - The NeoSmart Forums

not quite sure either, what’s going on, but you can do one of the two:

  1. pop in the opensuse 11.1 install disk chose repair system and fix your bootloader; or
  2. install winxp first, and then opensuse … never had a problem doing it in that order

@topiz: I did that with the openSuse DVD, but every time I boot from XP, Windows deletes the bootloader.

I don’t want to install anything now new

@zwenny: thank you for the links, but the bootloader worked and why is XP deleting the bootloader?

Is XP simply making it’s partition active, so the Generic boot code starts it, rather than GRUB?

Boot with Live CD, and see if the windows partition has the * under the ‘boot’ column.

By default, on single disk, I think GRUB gets installed into the /boot partion (usually /) rather than in MBR, with generic code in MBR to maximise compatability.

That has advantage, that Windows security software doesn’t decide a boot-virus has acted and overwrite GRUB boot code, but means toggling the boot flag is needed to go to GRUB boot menu, without openSUSE CD (which presumably can be clever) knowing about Linux partitions.

Perhaps you’ld have more luck, installing another Windows Boot manager, that is happy to make it simple to use another OS. MS want you to do 'dows and nothing else, remember!

maybe it’s because of your installation order?!
i’m getting this voice in my head to install
the less intelligent operating system :stuck_out_tongue: first
(and that’s win xp in your case).
i don’t know if windows recognizes an installed
linux os, but when i installed a multiboot system
back then, i proceeded in this order and never
had have problems so far.
if you like to (have the time), give it a try… :nerd:

XP didn’t recognize Linux, but I installed Linux new and lets see, if it goes better now.

Thanks for all