Xorg-x11-server update problem

I’m using OpenSUSE 11-4 with Gnome 3 and I’m getting the following error when updating the system:

patch:Mesa-4546.noarch conflicts with Mesa.x86_64 < 7.10.2-7.3.1 provided by Mesa-7.10-1.3.x86_64

The patch is for the xorg-x11-server. Does anyone know how to solve this?

I have the same problem, after installing (patch) I can not access the system

You must have missed me guys! I had the same issue. Solved. :slight_smile: Though I will add I had no bother accessing the system after installing it.

Thanks for the replies Ivanblago and Kinzie. I performed the online update from YaST and that sorted the problem.

…But, it’s created another problem. When I click on an icon in the top panel, I get an unrecoverable error message and then asked to log out. This must have been caused by the Mesa patch update. Is there a way to rollback the update from the command line or does anyone know of a better solution?

Great!! solved it!! Thanks for the heads up! :smiley:

Cduran1983, are you referring to the pre patch-update or post patch-update problem? If it’s the latter, how did you solve it?

Has anyone else had a problem after installing the Mesa-4546 patch, and managed to get it solved? Luckily, I made a cloned image of my system prior to the update and so was able to restore it from the backup, but I noticed that the Mesa patch increased the speed of the graphics system - the parabolic zoom of the Cairo Dock on my desktop was much more fluid than previously to the update - and was similar to the speed when using the proprietary fglrx drivers with Gnome 2. I’d prefer to use the patch-update so could do with some help in finding a solution.

Can anyone help me out with this?

Can anyone point me to where I can get this fixed? Thanks.

Go to Google search Mesa-7.10.2-7.3.1.x86_64.rpm and Mesa-nouveau3d-7.10.2-7.3.1.x86_64.rpm.
Download them,in root user, run:
rpm -Uvh Mesa-7.10.2-7.3.1.x86_64.rpm Mesa-nouveau3d-7.10.2-7.3.1.x86_64.rpm
The address of Mesa-7.10.2-7.3.1.x86_64.rpm:ftp://rpmfind.net/linux/opensuse/update/11.4/rpm/x86_64/Mesa-7.10.2-7.3.1.x86_64.rpm
The address of Mesa-nouveau3d-7.10.2-7.3.1.x86_64.rpm:ftp://rpmfind.net/linux/opensuse/update/11.4/rpm/x86_64/Mesa-nouveau3d-7.10.2-7.3.1.x86_64.rpm

Thanks for the links Youya. Before I follow your suggestion, am I right in that the Nouveau drivers are only meant for Nvidia cards or would your solution also work for ATI cards - mine is an ATI HD4830? I updated Mesa to 7.10.2-7.3.1.x86 from the repositories but I still have the same problem. I also posted a message 6 days ago at the Bugzilla link which is displayed with the Mesa patch description in Software Update, but I haven’t received a reply yet. I’d really like to get this sorted but I don’t know how to proceed from here.

The card of my PC is Nivida, so I am not sure about that question. The Mesa is a 3-D graphics library with an API which is very similar to
that of OpenGL. OpenGL is hardware-independent. Mesa is also the same. At present, Mesa-7.10.2-7.3.1 has not been incorporated into the openSUSE software sources. So if you don’t want to do some experiments on your PC, please be patient,I think that.

In addition, Mesa-7.10.2 was released April 6, 2011; so in openSUSE, it’s still being tested software.
The address of openSUSE update source is:
Index of /update/11.4
But the address of update-test source is:
Index of /update/11.4-test
You could add the test source to your software source using your zypper or your YaST2.
If you do that your software manager will be able to find Mesa-7.10.2-7.3.1.

It wasn’t really a problem after all then! I didn’t know that Mesa-7.10.2-7.3.1 was still in the experimental stage and I’m surprised that it showed up in the repositories as I haven’t any that are classed as ‘testing’ enabled. However, I downloaded a whole raft of updates yesterday and the problem has been fixed. :slight_smile: Thanks for the replies Youya, you set my mind at rest as I thought that I had a corrupted system file somewhere that was causing a conflict with the Mesa update.