xorg update/opengl update - ruined app

I’m running SuSE 11.2 and I have the NVidia driver installed from the NVidia company and not the one from Novell.
Recently I accepted an update for xorg.
This is from the zypp log:

2010-09-08 12:22:34|install|xorg-x11-Xvnc|7.4-61.64.1|i586||http-download.opensuse.org-7f346026|9136ed3b754311b7f5bad042e34ff633beb39b78
# 2010-09-08 12:22:38 xorg-x11-server-7.4-61.64.1.i586.rpm installed ok
# Additional rpm output:
# Updating etc/sysconfig/displaymanager...
# Starting SuSEconfig, the SuSE Configuration Tool...
# Running module permissions only
# Reading /etc/sysconfig and updating the system...
# Executing /sbin/conf.d/SuSEconfig.permissions...
# Checking permissions and ownerships - using the permissions files
# 	/etc/permissions
# 	/etc/permissions.easy
# 	/etc/permissions.d/mail-server
# 	/etc/permissions.d/postfix
# 	/etc/permissions.local
# setting /usr/bin/Xorg to root:root 4711. (wrong permissions 0711)
# Finished.
2010-09-08 12:22:38|install|xorg-x11-server|7.4-61.64.1|i586||http-download.opensuse.org-7f346026|291b42cf2f371270a745bb330d4811c06302243d
2010-09-09 12:24:07|install|libpng12-0|1.2.39-2.4.1|i586||http-download.opensuse.org-7f346026|f3605f2458066dd6dc92fa18bda061fff88f4ada
2010-09-09 12:24:09|install|libpng-devel|1.2.39-2.4.1|i586||http-download.opensuse.org-7f346026|a7301f0c68b2d8b54e3f1c68b6e943d9e2117654

Now my SweetHome3D app won’t start! It says:
“Fatal error in 3D rendering system.
Update DirectX Opengl drivers of your computer graphics card.”

I haven’t seen any updates for these from the updater applet yet.
How can I roll back that one update? My SweetHome 3D app worked nicely before this update and I just want it to work again.

I just tried to run Extreme Tux Racer but it too won’t start. Then I tried it in a terminal and this is what I got:

*** etracer error: Couldn't initialize video: Could not create GL context (Resource temporarily unavailable)

Then I tried SweetHome3D in a terminal and I got this:

Java 3D WARNING : reported GLX version = 1.2
    GLX version 1.3 or higher is required
    The reported version number may be incorrect.  There is a known
    ATI driver bug in glXQueryVersion that incorrectly reports the GLX
    version as 1.2 when it really is 1.3, so Java 3D will attempt to
    run anyway.
Canvas3D_createNewContext: couldn't create context
Error in Java 3D : 3 Renderer: Error creating Canvas3D graphics context

These two used to run just fine a few days ago (before the xorg update) with the same graphics card driver I now have:

Try reinstalling the driver.

In case of the kernel or xorg-packages being upgraded, you will always have to reinstall the driver when using NVidias .run-file instead of the package from the repository.

Thank you, I will try that out.

Eureka! That worked! My favorite app is now running again! :smiley:

When re-installing the driver, there was this error message: “File ‘/usr/lib/xorg/modules/extensions/libglx.so’ is not a symbolic link” So, what does that mean, and should I be worried?

I suppose that was not an error message but merely a warning, wasn’t it?

I suppose so. I snooped around in that folder and saw that that particular file links to another one that is probably newer or something (libglx.so.195.36.31 Dated for today 9/12/10)

I guess you should be okay with it.