Xorg high CPU usage on Gnome

Hi,

I see something rather strange. When logging on using Gnome as Desktop environment Xorg is using 99% of CPU. This does not happen when I use KDE or XFCE.
I’m running openSUSE 11.1 (i586) on a HP 6710b laptop.

Tasks: 137 total, 2 running, 135 sleeping, 0 stopped, 0 zombie
Cpu(s): 14.0%us, 37.9%sy, 0.0%ni, 45.8%id, 2.2%wa, 0.2%hi, 0.0%si, 0.0%st
Mem: 2063876k total, 1157600k used, 906276k free, 39584k buffers
Swap: 2104472k total, 0k used, 2104472k free, 661404k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
3232 root 20 0 350m 33m 9156 R 98 1.6 14:37.49 Xorg

rpm -qa | grep xorg-x11-server
xorg-x11-server-7.4-17.4.1

Someone has an idea on that? Need my xorg.conf?

Thanks for any input.

Cheers

Hi All !

My problem is that:
xorg is running with high cpu usage, why ?

Cpu(s): 22.4%us, 3.6%sy, 0.0%ni, 73.2%id, 0.6%wa, 0.2%hi, 0.0%si, 0.0%st
Mem: 2583632k total, 1873688k used, 709944k free, 99040k buffers
Swap: 2104472k total, 0k used, 2104472k free, 1206756k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
3789 root 20 0 472m 94m 6032 S 14 3.7 17:32.41 Xorg
25914 amaxi 20 0 58412 15m 12m S 6 0.6 6:14.74 ksysguard
5877 amaxi 20 0 64872 17m 11m S 5 0.7 6:32.64 kscience.kss

What is the problem ?

Thanks for the replay

Tutublu

tutubulu wrote:
> Hi All !
>
> My problem is that:
> xorg is running with high cpu usage, why ?
>
> CPU(S): 22.4%US, 3.6%SY, 0.0%NI, 73.2%ID, 0.6%WA, 0.2%HI,
> 0.0%SI, 0.0%ST
> MEM: 2583632K TOTAL, 1873688K USED, 709944K FREE, 99040K
> BUFFERS
> SWAP: 2104472K TOTAL, 0K USED, 2104472K FREE, 1206756K
> CACHED
>
> PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
> **3789 ROOT 20 0 472M 94M 6032 S _1_4 3.7 17:32.41 XORG
> 25914 amaxi 20 0 58412 15m 12m S 6 0.6 6:14.74 ksysguard
> 5877 amaxi 20 0 64872 17m 11m S 5 0.7 6:32.64
> kscience.kss
>
> What is the problem ?
>
> Thanks for the replay
>
> Tutublu
>
>

how did you decided that that is high?
high compared to what?

xorg is the windowing system…what do you have it doing? if it is,
for example showing a movie or spinning a 3D cube, or whatever, it is
working HARD…

what desktop environment are you using? KDE4 maybe…
and, what version openSUSE are you running…is it fully patched?

did you select a complicated theme with lots of curves to be
calculated, and 3d shading on every window edge, etc etc etc…

select a less resource hungry desktop environment, and a more modest
theme and your CPU will go down…

let us here


palladium
Have a lot of fun…
**

Thank you for your reply.
Now, I understand it.

So, I use 3D-Cube and more 3D application.
Yes, This is OpenSuse 11.1, and I haven’t installed patches yet.

Thank you for the information that I can understand deeper, how to works KDE4.

Tutubulu