Xorg coredumps at boots, black screen in graphical.target.

This started with kernel-5.15.5, so i locked kernel-default, filed a bug, and waited. Now it appears to be unrelated to the kernel. Here’s a list of the updates that cause this problem:

at least one of kernel-firmware-*
at least one package from the opensuse-release-20211206-1312.1 update.

Perhaps someone can see what is wrong from this coredump:

> sudo coredumpctl --no-pager -1 info
           PID: 1336 (Xorg.bin)
           UID: 0 (root)
           GID: 0 (root)
        Signal: 6 (ABRT)
     Timestamp: Wed 2021-12-08 09:26:04 PST (14min ago)
  Command Line: /usr/bin/Xorg.bin :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
    Executable: /usr/bin/Xorg.bin
 Control Group: /system.slice/display-manager.service
          Unit: display-manager.service
         Slice: system.slice
       Boot ID: 50dd1cb6d68047bb8aed85d816a2214a
    Machine ID: 4ea28cff055b4158913ff83dd6d354a3
      Hostname: Mobile-PC
       Storage: /var/lib/systemd/coredump/core.Xorg\x2ebin.0.50dd1cb6d68047bb8aed85d816a2214a.1336.1638984364000000.zst (present)
     Disk Size: 1.8M
       Message: Process 1336 (Xorg.bin) of user 0 dumped core.
                Found module linux-vdso.so.1 with build-id: ce1af37d979b84d6c61be2a123acb16c9522a727
                Found module libxcb-sync.so.1 with build-id: f81fb19dfc530a6bca2b342d8547c6aa5e84a5ff
                Found module libxcb-present.so.0 with build-id: deaf9c5e6849e60e620b9546aa011f0eda06c159
                Found module libxcb-dri3.so.0 with build-id: 77fb5e0eafff7365a81b5005dcb1e5d6b07a5f52
                Found module libwayland-client.so.0 with build-id: 907b609ececbe63c6a99d93d6504e6b20c05e757
                Found module libxcb-xfixes.so.0 with build-id: 4a1bc01c12aa7b027f8ba89b920ce86045b5b38b
                Found module libxcb-dri2.so.0 with build-id: 445e652e8d09d2a634eb0bf31d834360d41b8ae6
                Found module libX11-xcb.so.1 with build-id: beef164e70b6f187f4a07298017430f118e36525
                Found module libEGL_mesa.so.0 with build-id: d1056ca36344b47d318012845518d0f25e7cb271
                Found module libEGL.so.1 with build-id: d8ece0867109798b64d2ec21e7d3bad5e068a738
                Found module libwayland-server.so.0 with build-id: 7b18f5a4d0f96c6fcc4bd57f4bef5cbd7082affe
                Found module libepoxy.so.0 with build-id: 4980a50b7e34e7602d5bc9f527143ace8da8e075
                Found module libgbm.so.1 with build-id: a7050ca1ab803dd98930a73bac3efc8f110b2d2b
                Found module libglamoregl.so with build-id: 25aa7885c54e9c41f5ac39b53c48a22e39362fff
                Found module libpcre.so.1 with build-id: b24ed45c51c6b54dfc2f5a9b3c7358d08b95e8ff
                Found module libffi.so.8 with build-id: 360c0c7dbca0d85a3e7424f500bbbde0b16426d4
                Found module libglib-2.0.so.0 with build-id: bc9db0977dfc79d03b93c3dc02c821c437697a28
                Found module libgobject-2.0.so.0 with build-id: 5a0d0454a316b84149b3e8a243fabdd9b6845968
                Found module libgudev-1.0.so.0 with build-id: ffbf9aadca03f48cdcd2d9811c308ca9abf78269
                Found module libwacom.so.2 with build-id: 9ddfac135704f9bf6d2056f9cd5674b2a8d83636
                Found module libevdev.so.2 with build-id: 3fed791b4174331d3a159c167bc50f72bb798d10
                Found module libmtdev.so.1 with build-id: 9ec65f3fce20812d36b819252cea1cd55c782567
                Found module libinput.so.10 with build-id: a81096a8a92f088082a78293744fb06276056da3
                Found module libinput_drv.so with build-id: 61644cba61471df6f71df0d6bb9deb706c6a05e1
                Found module libxml2.so.2 with build-id: 05504d7dc6c871c734153a98ab62dfc615d44f92
                Found module libtinfo.so.6 with build-id: 3ba27b8e25b1c74a1b948e9c6a0d676a81f921d8
                Found module libedit.so.0 with build-id: a021b58d2419762f592d73feae3bc50eef530114
                Found module libstdc++.so.6 with build-id: ba4653924b2dddc074395b3f96dd57db3fbc7c67
                Found module libdrm_nouveau.so.2 with build-id: 40cd6f94ea29b194e4f8add719885d49b1a44807
                Found module libdrm_amdgpu.so.1 with build-id: 4d88156495d9f3031157f3b05b8bc4348909f9d0
                Found module libelf.so.1 with build-id: 1e900f06c475692fbe58c77b3430485dc6691c0f
                Found module libdrm_radeon.so.1 with build-id: 4095978fe3c7c0b62df8d0642316993c8e02987a
                Found module libexpat.so.1 with build-id: e4a8afcbd0f5d33569c34d0831dbd1ee2aaa306b
                Found module libLLVM.so.13 with build-id: fa4d45a054c24fe3fc0cc9c8a9155a91b4724a24
                Found module libglapi.so.0 with build-id: 6f5cde4ef858d2107c94e27b5d3f3aa23761e01c
                Found module swrast_dri.so with build-id: 04054cec91075ddbcf08ebe6f48c5116ee571e7c
                Found module libshadow.so with build-id: 554e52ee0b8a88b0c8ecbe0649d356b9c19cbd57
                Found module libfbdevhw.so with build-id: ab05ba6362f05a1edcc6960033a1ebb17d31e2c6
                Found module fbdev_drv.so with build-id: 6a6365ab317e0bcffa4b7fc072ed904230d94bde
                Found module modesetting_drv.so with build-id: 7c769c9497bcbf6327a9720c28098cae8368d60a
                Found module ati_drv.so with build-id: 589b97337e5f86dcf39f669cd9c80a286d4a6aea
                Found module libxcb.so.1 with build-id: 4159a44f03f9d58e122f48f915e7f6043bd222bc
                Found module libX11.so.6 with build-id: b01e964fc599b7153e6cf33769a47c74c124f5df
                Found module libGLdispatch.so.0 with build-id: da054471ef2b590037c25fe4fac23ea245c6f093
                Found module libGLX.so.0 with build-id: 483abfe80f77d141775a78382c8a105059278247
                Found module libGL.so.1 with build-id: 1b7503d815b08e3b3ad1cda232d42bec0da25d87
                Found module libglx.so with build-id: a355a52a1d2a027f5e2c76e999856fdbaa95cc26
                Found module libgcc_s.so.1 with build-id: bb736f96c2fa46da03cf1ad03e6c4ce63978cc82
                Found module libbrotlicommon.so.1 with build-id: 6686aa325d4afdb805e780ca00c6c1ee8355c0ec
                Found module libgpg-error.so.0 with build-id: 045008a24a228dc0771bbb07dbe48e97a83c0e1f
                Found module libbrotlidec.so.1 with build-id: b1a64db9f269d9241cf4642ab820373edf56af85
                Found module libpng16.so.16 with build-id: 78afe6992bb3326434c28f8ba19ad875b6194850
                Found module libbz2.so.1 with build-id: fb7461db07ad3fbbcdb675cc400776e9f930c70b
                Found module libgcrypt.so.20 with build-id: b42217713b6dde01b56599aa5f277a19ebbcdc70
                Found module libcap.so.2 with build-id: faaca623aa72af75247cc8d9b27480b583d99929
                Found module liblz4.so.1 with build-id: 968ac2baa13e3e1f97143a2688713db9b1d66102
                Found module libzstd.so.1 with build-id: 171a1a1f4fb732f38b5a392e24b33e0a53b2be94
                Found module liblzma.so.5 with build-id: 114f5de77af42eeae25b95718dfee184e2cab587
                Found module libfreetype.so.6 with build-id: f4dae8e503891268bd2fe5b872fcfcf2a1d60d82
                Found module libfontenc.so.1 with build-id: f5a2d7ee3600ecb91b973f2d6307fcd9cca0ba34
                Found module libz.so.1 with build-id: ca0254f7e149a787d1aa310d7652cb9da10ddb6c
                Found module ld-linux-x86-64.so.2 with build-id: cd9883e74273975ef100d73eb921622177e39a46
                Found module libc.so.6 with build-id: 470ba8f19ab5d1c9e585cccd7133c4af51a4ca7d
                Found module libm.so.6 with build-id: e58e8214a9ec4b49894d4323efc3e5fe4eaf3e1c
                Found module libXdmcp.so.6 with build-id: d9cb32e5fd975f457f6f2790944008f10aca7bc2
                Found module libxshmfence.so.1 with build-id: 5521d73f237b67919d8c88f245bd5a7502211ccf
                Found module libsystemd.so.0 with build-id: 6a053a97e8329f0f2d080c5e167707a5bcfaaf2e
                Found module libXau.so.6 with build-id: 6380e242b53ea6076bea41d5367d97dfd612fca1
                Found module libXfont2.so.2 with build-id: 1773aee431bb7e9404c2b93a2966bfdf540ddef6
                Found module libpixman-1.so.0 with build-id: b0dbb7a2b1154f0c72279fcb325ed46e63c54d79
                Found module libdrm.so.2 with build-id: 91170bb840afd3e5ea3096d10248eb45252fed9a
                Found module libpciaccess.so.0 with build-id: 9857f209666b7e9edbf91ed56e4971d210cd799b
                Found module libxcvt.so.0 with build-id: e5fe9cc8feac39b8931e8b9df345aeede1523fbe
                Found module libcrypto.so.1.1 with build-id: 6ced5f5f876441f4645c0e75c677002b2c819074
                Found module libudev.so.1 with build-id: 19dc06e83699753df9a6b37391e76602432fb09c
                Found module libdbus-1.so.3 with build-id: bc8cf3d9904849b0fb018e6eca353afa2c2450eb
                Found module Xorg.bin with build-id: 6a380c7568d82ec526415abff2f20645b98c0cc7
                Stack trace of thread 1336:
                #0  0x00007f575e9cd29c __pthread_kill_implementation (libc.so.6 + 0xa629c)
                #1  0x00007f575e97d366 raise (libc.so.6 + 0x56366)
                #2  0x00007f575e9667d3 abort (libc.so.6 + 0x3f7d3)
                #3  0x00005561cee9882c OsAbort (Xorg.bin + 0x1d982c)
                #4  0x00005561ceea10e0 FatalError (Xorg.bin + 0x1e20e0)
                #5  0x00005561cee97276 n/a (Xorg.bin + 0x1d8276)
                #6  0x00007f575e97d430 __restore_rt (libc.so.6 + 0x56430)
                #7  0x00007f575e9cd29c __pthread_kill_implementation (libc.so.6 + 0xa629c)
                #8  0x00007f575e97d366 raise (libc.so.6 + 0x56366)
                #9  0x00007f575e9667d3 abort (libc.so.6 + 0x3f7d3)
                #10 0x00007f575e9666eb __assert_fail_base.cold (libc.so.6 + 0x3f6eb)
                #11 0x00007f575e975956 __assert_fail (libc.so.6 + 0x4e956)
                #12 0x00005561ced42b51 n/a (Xorg.bin + 0x83b51)
                #13 0x00007f57545116bb glamor_init (libglamoregl.so + 0xd6bb)
                #14 0x00007f575e0463a1 n/a (modesetting_drv.so + 0xf3a1)
                #15 0x00005561ced1fcfe AddGPUScreen (Xorg.bin + 0x60cfe)
                #16 0x00005561ced84819 n/a (Xorg.bin + 0xc5819)
                #17 0x00005561ced8c1f0 n/a (Xorg.bin + 0xcd1f0)
                #18 0x00005561ced85b61 n/a (Xorg.bin + 0xc6b61)
                #19 0x00005561ced86150 n/a (Xorg.bin + 0xc7150)
                #20 0x00005561cee9a411 n/a (Xorg.bin + 0x1db411)
                #21 0x00005561cee940c0 WaitForSomething (Xorg.bin + 0x1d50c0)
                #22 0x00005561ced0b369 n/a (Xorg.bin + 0x4c369)
                #23 0x00007f575e9675c0 __libc_start_call_main (libc.so.6 + 0x405c0)
                #24 0x00007f575e96767c __libc_start_main@@GLIBC_2.34 (libc.so.6 + 0x4067c)
                #25 0x00005561ced0be35 _start (Xorg.bin + 0x4ce35)
                Stack trace of thread 1555:



I’ve been running for quite some time with several updates after removing some packages I thought were unneeded. However, I was mistaken. After running:

> sudo zypper install plymouth plymouth-branding-openSUSE plymouth-dracut plymouth-plugin-label plymouth-plugin-label-ft plymouth-plugin-two-step plymouth-scripts plymouth-theme-bgrt plymouth-theme-spinner^Cf86-video-ati xf86-video-mach64 xf86-video-r128

I’m able to update with sudo zypper dup and no locks. Any guesses which package(s) broke xorg?


None of those packages installed on any system here, plymouth gets removed from the get go… likewise for those video drivers. Suggest you upgrade to the 5.15.6 kernel along with the Mesa and Xorg updates to get to snapshot 20211206.

That’s interesting. I’ll try removing them again and see what happens at the next update. I was able to update to snapshot 20211206 after I reinstalled those packages. Odd.


Just make sure you run mkinitrd after to removal to remove the kernel module.

I had forgotten to run mkinitrd after I removed the packages, so I ran it as you suggested. On reboot, xorg crashed again, and X failed to start.

So I reinstalled the xf86-video-ati xf86-video-mach64 xf86-video-r128 packages and xorg still crashed.

Then I reinstalled the plymouth packages, and xorg started at reboot.

I uninstalled xf86-video-ati xf86-video-mach64 xf86-video-r128, ran mkinitrd, and xorg still starts at boot.

So on my system, something causes xorg to coredump during boot if those nine plymouth packages are removed, followed by mkinitrd, followed by a reboot.


I also omit the plymouth module via dracut.

As a test, next time you boot, press e to edit grub and add the following option to disable at boot;


After editing the boot command line, I got a successful boot. This is what the command line line should like?

> cat /proc/cmdline 
BOOT_IMAGE=/boot/vmlinuz-5.15.6-1-default root=UUID=8e2eab35-ae1a-4e73-85ef-db7bf3142a2c splash=verbose mitigations=auto plymouth.enable=0

I’m sure that xorg will break if i remove the nine plymouth packages, run mkinitrd, and reboot again though. Want me to try?


Well that disables plymouth, I would add via YaST bootloader to make permanent…

Plymouth running isn’t really the problem. I’m trying to understand why removing the plymouth packages causes Xorg.bin to coredump. From my understanding of how your machines are configured, that’s not normal behavior. I’m not sure how to trouble shoot the connection between removing plymouth and causing Xorg.bin to coredump during boot, though.


Then only thing I do it remove packages omit the plymouth module;

cat /etc/dracut.conf.d/01-grover 


omit_dracutmodules+=" plymouth "

Then run mkinitrd, note I do exclude many other unnecessary modules and drivers.

The latter two of those three are for ancient ATI cards, older than roughly 20+ years. The first is for old ATI cards (provides radeon display driver), mostly Radeons, cards made before GCN and the amdgpu driver were introduced.

None of my many installations have Plymouth installed, so I have no first-hand experience using it or what it depends on, or what depends on it. Plymouth likely affects the DMs, as it runs first, only until a DM (and Xorg) starts. Does switching to some other DM help?

Are you using automatic login? If yes, turn it off for further troubleshooting.


I copied the contents of your /etc/dracut.conf.d/01-grover file to /etc/dracut.conf.d/01-local.conf on my machine, removed the plymouth packages and ran mkinitrd. On reboot, Xorg.bin coredumped again. So I reinstalled the plymouth packages which ran dracut with that file still in place, and Xorg.bin still crashed.

I removed the file /etc/dracut.conf.d/01-local.conf and ran mkinitrd, and now Xorg.bin runs to completion and X starts. So on my system, plymouth must be in the initrd, or I’m unable to boot to the graphical.target. However, I can boot successfully with “plymouth.enable=0” in the boot command line.

Also, I can remove the plymouth packages and reboot successfully until the next time dracut is called, e.g., when a new kernel or driver is installed. This is what happened originally. I removed the packages and the system behaved normally, even through a few runs of “zypper dup”, until dracut ran when a new kernel was installed. So I created a time bomb by removing the plymouth packages.


No, I’m not running automatic login, and I’ve always been able to remove plymouth on Fedora installations. I always used lightdm on Fedora, and I’m using it here. I might try another DM tomorrow. This is a new problem for me.

Thanks for the insights,

So you can list whats in there with the lsinitrd command (as root user)

lsinitrd | grep plymouth

Never seen that…

I’ll be out of town most of today, but I’ve done a little looking and found the following results when dracut is run with the file 01-local.conf in /etc/dracut.conf.d:

# cat 01-local.conf
omit_dracutmodules+=" plymouth "

# cat lsinitrd_plymouth
drwxr-xr-x   1 root     root            0 Nov 24 15:02 etc/systemd/system/systemd-ask-password-plymouth.service.wants
lrwxrwxrwx   1 root     root           54 Nov 24 15:02 etc/systemd/system/systemd-ask-password-plymouth.service.wants/systemd-vconsole-setup.service -> /usr/lib/systemd/system/systemd-vconsole-setup.service
-rw-r--r--   1 root     root          454 Nov 24 15:02 usr/lib/systemd/system/systemd-ask-password-plymouth.path
-rw-r--r--   1 root     root          435 Nov 24 15:02 usr/lib/systemd/system/systemd-ask-password-plymouth.service

# grep plymouth dmesg_out
    4.302331] systemd[1]: unit_file_build_name_map: normal unit file: /usr/lib/systemd/system/systemd-ask-password-plymouth.service
    4.302942] systemd[1]: unit_file_build_name_map: normal unit file: /usr/lib/systemd/system/systemd-ask-password-plymouth.path
    4.347930] systemd[1]: plymouth-start.service: Failed to load configuration: No such file or directory

# cat journal_err
-- Journal begins at Sun 2021-11-07 09:17:49 PST, ends at Thu 2021-12-09 09:21:42 PST. --
Dec 09 07:59:07 Mobile-PC systemd[1]: Failed to start X Display Manager.
Dec 09 07:59:08 Mobile-PC systemd-backlight[1638]: Failed to get backlight or LED device 'backlight:acpi_video0': No such device
Dec 09 07:59:08 Mobile-PC systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0.
Dec 09 08:01:42 Mobile-PC login[1312]: gkr-pam: unable to locate daemon control file
Dec 09 09:17:01 Mobile-PC kernel: iommu ivhd0: AMD-Vi: Event logged [INVALID_DEVICE_REQUEST device=00:00.0 pasid=0x00000 address=0xfffffffdf8000000 flags=0x0a00]

# cat status_display-manager.service
× display-manager.service - X Display Manager
     Loaded: loaded (/usr/lib/systemd/system/display-manager.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Thu 2021-12-09 07:59:07 PST; 1h 19min ago
    Process: 1400 ExecStart=/usr/lib/X11/display-manager start (code=exited, status=1/FAILURE)
        CPU: 75ms

Dec 09 07:59:07 Mobile-PC systemd[1]: display-manager.service: Failed with result 'exit-code'.
Dec 09 07:59:07 Mobile-PC systemd[1]: display-manager.service: Service will not restart (restart setting)
Dec 09 07:59:07 Mobile-PC systemd[1]: display-manager.service: Changed start -> failed
Dec 09 07:59:07 Mobile-PC systemd[1]: display-manager.service: Job 295 display-manager.service/start finished, result=failed
Dec 09 07:59:07 Mobile-PC systemd[1]: Failed to start X Display Manager.
Dec 09 07:59:07 Mobile-PC systemd[1]: display-manager.service: Unit entered failed state.
Dec 09 07:59:07 Mobile-PC systemd[1]: display-manager.service: Triggering OnFailure= dependencies.
Dec 09 07:59:07 Mobile-PC systemd[1]: display-manager.service: Triggering OnFailure= dependencies done.
Dec 09 07:59:07 Mobile-PC systemd[1]: display-manager.service: Consumed 75ms CPU time.
Dec 09 07:59:07 Mobile-PC systemd[1]: display-manager.service: Control group is empty.

Do you see anything useful in there?


There are multiple known regressions in TW’s Xorg. Some of them can be solved or worked around via xrandr --auto. It can be hosted by a script in /etc/X11/xinit/xinitrc.d/.