xorg.conf file

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 1.0 (buildmeister@builder58) Tue Oct 20 21:25:04 PDT 2009

/…/

SaX generated X11 config file

Created on: 2009-09-18T10:02:19-0400.

Version: 8.1

Contact: Marcus Schaefer <sax@suse.de>, 2005

Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>

Automatically generated by [ISaX] (8.1)

PLEASE DO NOT EDIT THIS FILE!

Section “ServerLayout”
Identifier “Layout[all]”
Screen “Screen[0]” 0 0
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
Option “Clone” “off”
Option “Xinerama” “off”
EndSection

Section “Files”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
EndSection

Section “Module”
Load “dbe”
Load “freetype”
Load “extmod”
Load “glx”
EndSection

Section “ServerFlags”
Option “AutoAddDevices” “off”
Option “AllowMouseOpenFail” “on”
Option “ZapWarning” “on”
EndSection

Section “InputDevice”
Identifier “Keyboard[0]”
Driver “kbd”
Option “Protocol” “Standard”
Option “XkbLayout” “us”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”
EndSection

Section “InputDevice”
Identifier “Mouse[1]”
Driver “mouse”
Option “Buttons” “3”
Option “Device” “/dev/input/mice”
Option “Name” “NewScroll (ImPS/2 Version)”
Option “Protocol” “Auto”
Option “Vendor” “Genius”

Option “ZAxisMapping” “4 5”

EndSection

Section “Modes”
Identifier “Modes[0]”
EndSection

Section “Monitor”
Identifier “Monitor[0]”
VendorName “DELL”
ModelName “2208WFP(Digital)”
UseModes “Modes[0]”
DisplaySize 467 263
HorizSync 31.0 - 83.0
VertRefresh 56.0 - 75.0
Option “CalcAlgorithm” “XServerPool”
Option “DPMS”
Option “PreferredMode” “1920x1080”
Option “NoLogo”
Option “AddARGBVisuals” “True”
Option “AddARGBGLXVisuals” “True”
Option “DynamicTwinView” “false”
Option “RenderAccel” “true”
Option “AllowGLXWithComposite” “true”
EndSection

Section “Device”
Identifier “Device[0]”
Driver “nvidia”
VendorName “NVidia”
BoardName “GeForce 9500 GT”
EndSection

Section “Screen”
Identifier “Screen[0]”
Device “Device[0]”
Monitor “Monitor[0]”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1920x1080” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 16
Modes “1920x1080” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 24
Modes “1920x1080” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 32
Modes “1920x1080” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 8
Modes “1920x1080” “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
EndSection

Section “Extensions”
Option “RENDER” “true”
Option “DAMAGE” “true”
Option “Composite” “Enable”
EndSection

Copy this in kwrite and save in/home/xxxxx/xorg.conf
su
passwrd

cp xorg.conf /etc/X11

From here you can edit the file to your needs
:wink:

You want to give Knurpht a heart attack ?

please_try_again

Why should i?

susegebr wrote:
> please_try_again
>
> Why should i?

who are you sending that xorg.conf to? and why?
is it supposed to be a solution for something, or what?


palladium

many complaints on forum that nvidia-xconfig does not work because it cant find a xorg.conf

If nvidia or ati was working before copy this xorg.conf to /etc/X11 edit it install the driver and reboot

Thats the meaning of this action :wink:

I don’t know when and why nvidia-xconfig doesn’t work (but I know that it happens). However this is not (or not always?) because of a missing xorg.conf.

#mv /etc/X11/xorg.conf{,.test} && nvidia-xconfig

WARNING: Unable to locate/open X configuration file.

New X configuration file written to '/ect/X11/xorg.conf'

Ummm … NO. That won’t work for everyone with an NVidia or ATI. That will only work with people who have similar hardware to your own. The xorg.conf file doesn’t just address the video driver, it has info on the monitor, mouse and keyboard as well. For example,

Section “Monitor”
Identifier “Monitor[0]”
VendorName “DELL”
ModelName “2208WFP(Digital)”
UseModes “Modes[0]”
DisplaySize 467 263
HorizSync 31.0 - 83.0
VertRefresh 56.0 - 75.0
Option “CalcAlgorithm” “XServerPool”
Option “DPMS”
Option “PreferredMode” “1920x1080”
Option “NoLogo”
Option “AddARGBVisuals” “True”
Option “AddARGBGLXVisuals” “True”
Option “DynamicTwinView” “false”
Option “RenderAccel” “true”
Option “AllowGLXWithComposite” “true”
EndSection

May NOT work with a monitor other than a Dell 2208WFP at 1920x1080 resolution.

As a general rule and FYI, you can’t copy a config file from one machine and expect it to work on another. This would cause more problems than it would solve.

As for your assertion that a “missing xorg.conf” is a common problem, that’s not the case, either. The biggest cause of lost video complaints in this forum is a kernel update requiring a reload/rebuild of the driver(s). Just for the record, I’ve never lost my xorg.conf file.

but, you don’t realize that not everyone using openSUSE is also using
a standard USA keyboard, a 3 button Genius mouse, a DELL 2208WFP
digital monitor, a NVidia GeForce 9500 GT graphics adapter, and want
composit enabled…

your good hearted initiative is highly commendable…but, your in
depth understanding of the solution to other people’s potential
problem of nvidia-xconfig not finding an xorg.conf file is a little
lacking…

i’d advise no one (even those with the exact hardware specified in
para one) to copy paste in the configure file offered…it could
simply result in a black screen or might even do some
damage…depending on the display you use…


palladium

susegbr,

In your xorg.conf

  • The Files section is irrelevant
  • The InputDevice sections are deprecated and will be ignored
  • The Monitor section is useless (if not dangerous anymore). In the past, people following your advice could have fried their monitor. Fortunately, nowadays, they will just see an ‘input signal out of range’ .
  • Same thing for the mode lines in your Screen section.
  • The Device section is obvious and will be created by nvidia-xconfig anyway with obvious values :
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"

  • Option “Composite” “Enable” is not going to help anybody getting his graphic card to work.

However, copying /etc/X11/xorg.conf from an older version, or another Linux distro or another Unix is not always a bad idea and can indeed solve problems. But you should do that only and exclusively on the same machine (and not switch monitors in the meantime). You can take that basically as a rule: Do not share your /etc/X11/xorg.conf with anybody.

That bears repeating.

It’s a bad idea to share ANY config file with anyone else unless you know what you’re doing, and know for a fact that they have exactly the same setup.

susegebr wrote:

> Section “Modes”
> Identifier “Modes[0]”
> EndSection
>

This section will bite you in the butt. I have to insert the mode lines for
my nvidia card - which hal doesn’t get because of some conflict trying to
read the data during boot due to an APIC conflict. PITA, but I’ve had this
issue with autodetection since 11.0 on this one machine.


Will Honea

The mods have discussed this issue. We recognise the good intentions of the OP, susegbr, and extend thanks to *susegbr *for starting this discussion.

However we feel we should state for the benefit of new users that it would be unwise to use the *xorg.conf *of any other person directly. As other members of have pointed out, different hardware requires xorg.conf files that differ widely from each other.

The mods close this thread and hope that new users will read it till the end to digest the full discussion.

Thanks to all for their contributions.