xorg.conf can't be saved?

I was trying to modify my logitech mx518 mouse so that all buttons could be used.

i copied the following to it

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[1]”
Option “Buttons” “7”
Option “Device” “/dev/input/mice”
Option “Name” “ImExPS/2 Logitech Explorer Mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
Option “ButtonMapping” “1 2 3 6 7”
EndSection

before i tried to save it i got a message stating

For file /etc/X11/xorg.conf no backup copy could be created before saving. If an error occurs while saving, you might lose the data of this file. A reason could be that the media you write to is full or the directory of the file is read-only for you.

Then i selected “Try to save nevertheless” and got the message

The document could not be saved, as it was not possible to write to /etc/X11/xorg.conf.

Check that you have write access to this file or that enough disk space is available.

I also had permission within the etc folder to modify files.

did you su to root before editing ? or are you using filemanager-superuser mode ? The xorg filesneed admin priviledges to edit & save

Andy

Im kinda new to linux i followed the instructions in this thread
Logitech Mx518 - openSUSE Forums

Hi,

to edit your xorg.conf hit alt+f2 to open krunner. Then type this (or just copy and paste it):

kdesu kwrite /etc/X11/xorg.conf

Enter your root password when it asks.

Then you’ll be able to save it.

Good Luck,

Ian

thanks that worked. unfortunately my mouse ended up with less features instead of more , i guess i’ll have to go back to the default :frowning: