Xmodmap + remote X console + hungarian keyboard


I am not a newbie in SuSE but I have a big problem with openSuSE 11.0. We use this software since 8.2 and I could solve anything till this day…We have an application server running SuSE / openSuSE ( currenty oS 11.0, and KDE 3.5 ) and we have a lot of X terminals. Some boot from network, some from CD and the rest from USB and we have different distribs ( Suse, Slax, Debian so this palette is very colorful :slight_smile: ). They works well for years and SuSE is works well too.

I always had the problem when I start a remote X console there are no hungarian keyboard. Till this moment I could solve this problem ( beginning with 8.2 through 9.2, 9.3, 10.0, 10.1 )with xmodmap and a very very old gnome xmodmap directory containing an xmodmap.hu file having the right layout for hungarian keyboards. But when I tried to use with 11.0 my keyboard gets messed and only restart helps me out from this situation.

Locally the hungarian keyboard is exists and working properly but when I try to use it from another X console remotelly only english layout present. I tried to find a way to get hungarian layout but I got nowhere…

Please help me how can I get hungarian keyboard to my remote X consoles?

Maybe a bug:

When I want to run startx as root at runlevel 3 locally or remotely the machine freezes, only reset wakes up it.

Thread moving from General to Application. Closing thread till move complete.

Move complete, thread re-opened.