Xlib: extension "GLX" missing on display ":0".

Hello All,

I’m afraid this is that time of the year in which for some reason my nVidia driver decides not to work properly.

When I try to run programs like hugin I got this error:

 Xlib:  extension "GLX" missing on display ":0".

nvidia-settings gives this instead:

Xlib:  extension "GLX" missing on display ":0".
[VS] Software VDPAU backend library initialized
Xlib:  extension "GLX" missing on display ":0".
[VS] error (glx_ctx_ref_glc_hash_table): glXChooseVisual failed

Below some info about my system. I am running suse 13.2, this is the output of rpm -qa | egrep “nvidia|kernel”:

kernel-desktop-3.11.10-25.1.x86_64
nvidia-uvm-gfxG03-kmp-desktop-340.65_k3.16.6_2-32.1.x86_64
nvidia-uvm-gfxG03-kmp-desktop-340.46_k3.11.6_4-33.1.x86_64
nvidia-gfxG03-kmp-desktop-340.76_k3.16.6_2-39.1.x86_64
nvidia-uvm-gfxG03-kmp-desktop-340.76_k3.16.6_2-36.1.x86_64
nvidia-computeG03-340.76-39.1.x86_64
nvidia-uvm-gfxG03-kmp-desktop-340.65_k3.11.6_4-32.1.x86_64
kernel-desktop-devel-3.16.7-21.1.x86_64
nvidia-gfxG03-kmp-desktop-340.46_k3.11.6_4-30.1.x86_64
nvidia-uvm-gfxG03-kmp-desktop-340.58_k3.11.6_4-31.1.x86_64
nvidia-uvm-gfxG03-kmp-desktop-340.76_k3.16.6_2-39.1.x86_64
texlive-l3kernel-2013.84.svn_4469svn29409-16.1.7.noarch
kernel-devel-3.16.7-21.1.noarch
kernel-desktop-devel-3.16.7-7.1.x86_64
kernel-desktop-3.16.7-7.1.x86_64
nvidia-glG03-340.76-39.1.x86_64
nvidia-gfxG03-kmp-desktop-340.65_k3.16.6_2-32.1.x86_64
kernel-desktop-3.11.10-21.1.x86_64
nvidia-gfxG03-kmp-desktop-340.76_k3.16.6_2-36.1.x86_64
kernel-firmware-20141122git-5.1.noarch
nvidia-texture-tools-2.0.6-25.1.8.x86_64
kernel-desktop-devel-3.11.10-25.1.x86_64
kernel-desktop-3.16.7-21.1.x86_64
nvidia-gfxG03-kmp-desktop-340.58_k3.11.6_4-31.1.x86_64
kernel-devel-3.16.7-7.1.noarch
nvidia-uvm-gfxG03-kmp-desktop-340.46_k3.11.6_4-30.1.x86_64
nvidia-gfxG03-kmp-desktop-340.65_k3.11.6_4-32.1.x86_64
x11-video-nvidiaG03-340.76-39.1.x86_64
kernel-devel-3.11.10-21.1.noarch
kernel-macros-3.16.7-21.1.noarch
nvidia-gfxG03-kmp-desktop-340.46_k3.11.6_4-33.1.x86_64
kernel-devel-3.11.10-25.1.noarch
kernel-desktop-devel-3.11.10-21.1.x86_64

Now, I am sure that my graphic card should work with the gfxG03 drivers, but am I supposed to have different versions?
When I installed them the first time, I used the easy way and went for the nVidia repo installation.

Also, I found there’s an error message in my Xorg.0.conf

    39.801] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
    39.801] (==) NVIDIA(0): RGB weight 888
    39.801] (==) NVIDIA(0): Default visual is TrueColor
    39.801] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
    39.801] (**) NVIDIA(0): Option "Stereo" "0"
    39.801] (**) NVIDIA(0): Option "nvidiaXineramaInfoOrder" "DFP-0"
    39.801] (**) NVIDIA(0): Option "SLI" "Off"
    39.801] (**) NVIDIA(0): Option "MultiGPU" "Off"
    39.801] (**) NVIDIA(0): Option "BaseMosaic" "off"
    39.801] (**) NVIDIA(0): Stereo disabled by request
    39.801] (**) NVIDIA(0): NVIDIA SLI disabled.
    39.801] (**) NVIDIA(0): NVIDIA Multi-GPU disabled.
    39.801] (**) NVIDIA(0): Option "MetaModes" "LVDS-0: nvidia-auto-select +0+0"
    39.801] (**) NVIDIA(0): Option "RegistryDwords" "EnableBrightnessControl=1;PowerMizerEnable=0x1;PerfLevelSrc=0x3333;PowerMizerLevel=0x3;PowerMizerDefault=0x3;PowerMizerDefaultAC=0x3"
    39.801] (**) NVIDIA(0): Enabling 2D acceleration
**    39.801] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X**
**    39.801] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X**
**    39.801] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If**
**    39.801] (EE) NVIDIA(0):     you continue to encounter problems, Please try**
**    39.801] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.**
    40.560] (II) NVIDIA(0): Display (MS_ Nvidia Default Flat Panel (DFP-0)) does not
    40.560] (II) NVIDIA(0):     support NVIDIA 3D Vision stereo.
    40.560] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20150116)
    40.561] (II) NVIDIA(0): NVIDIA GPU GeForce GT 425M (GF108) at PCI:1:0:0 (GPU-0)
    40.561] (--) NVIDIA(0): Memory: 1048576 kBytes
    40.561] (--) NVIDIA(0): VideoBIOS: 70.08.19.00.47
    40.561] (II) NVIDIA(0): Detected PCI Express Link width: 16X
    40.564] (--) NVIDIA(0): Valid display device(s) on GeForce GT 425M at PCI:1:0:0
    40.564] (--) NVIDIA(0):     CRT-0
    40.564] (--) NVIDIA(0):     MS_ Nvidia Default Flat Panel (DFP-0) (boot, connected)
    40.564] (--) NVIDIA(0):     DFP-1
    40.564] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
    40.564] (--) NVIDIA(0): MS_ Nvidia Default Flat Panel (DFP-0): Internal LVDS
    40.564] (--) NVIDIA(GPU-0): MS_ Nvidia Default Flat Panel (DFP-0): 330.0 MHz maximum pixel clock
    40.564] (--) NVIDIA(0): DFP-1: Internal TMDS
    40.564] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
    40.564] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
    40.564] (**) NVIDIA(0):     device MS_ Nvidia Default Flat Panel (DFP-0) (Using EDID
    40.564] (**) NVIDIA(0):     frequencies has been enabled on all display devices.)
    40.565] (II) NVIDIA(0): Validated MetaModes:
    40.565] (II) NVIDIA(0):     "LVDS-0:nvidia-auto-select+0+0"
    40.565] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
    41.384] (--) NVIDIA(0): DPI set to (135, 137); computed from "UseEdidDpi" X config
    41.384] (--) NVIDIA(0):     option
    41.384] (--) Depth 24 pixmap format is 32 bpp
    41.384] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
    41.384] (II) NVIDIA:     access.
    41.397] (II) NVIDIA(0): Setting mode "LVDS-0:nvidia-auto-select+0+0"
    41.801] (==) NVIDIA(0): Disabling shared memory pixmaps
    41.801] (==) NVIDIA(0): Backing store enabled
    41.801] (==) NVIDIA(0): Silken mouse enabled
    41.801] (**) NVIDIA(0): DPMS enabled

Any suggestions?
Thanks in advance

You might want to remove the old 13.1 kernels and nvidia kmp packages then and/or check that purge-kernels.service is enabled (it doesn’t seem to be since you have too many kernels installed), but that shouldn’t cause your problem.

Unfortunately you didn’t post the whole Xorg.0.log, so one cannot see where libglx is actually loaded from and which version it is or why it failed.

But as this seems to be a system upgraded from 13.1, there might be some older version left in /usr/lib64/xorg/modules/updates/extensions/ (you should actually delete the whole /usr/lib64/xorg/modules/updates/ folder if it exists).
On 13.1, nvidia’s libglx was installed to that directory and this overrides the standard one that is used in 13.2. So if the files have been left-over, the old (incompatible) ones are used instead (this might even work for a while, but as soon as an updated driver is released this breaks for hopefully obvious reasons).

If that doesn’t help, try to reinstall nvidia-glG03. On 13.2 the libglx to use is set via “update-alternatives”. If something went wrong, Xorg’s libglx might be in use which doesn’t work with the nvidia driver.

sudo zypper in -f nvidia-glG03

Removing the directory worked like a charm! Also, thank you for the tip about the purge-kernel, it was inactive indeed.

Many thanks again!