xinetd not working

I am using Opensuse 11.0 in text mode. I’ve added mldonkey services to xinetd and then i tried to reboot xinetd ( /etc/init.d/xinetd restart ) and i get:
Shutting down xinetd:
Starting INET services. (xinetd) failed

So i deleted my service ( mldonkey ) and tried again, same error… Can’t get xinetd working… ideas?

mldonkey gives problem: here is /etc/xinetd.d/mldonkey:
GNU nano 2.0.7 File: mldonkey

service mldonkey
disable = no
socket_type = stream
protocol = tcp
wait = no
user = marco
server = /usr/bin/mldonkey

Is there an entry for mldonkey in your /etc/services?

No, there isn’t… What should i add to it?

Well, mldonkey is only the name of the port to be used. The real portnumber is in /etc/services. You can e.g. see:

http             80/tcp    # World Wide Web HTTP
http             80/udp    # World Wide Web HTTP

that http uses the (well known) port 80. I do not know which port is normaly to be used with your product (mldonkey). That should be somewhere in the documentation.

You could asign any port not used on your system (above 1025 when the server is to be run by a normal user), but as the client will try to connect to that port the client must know about it.

I could e.g. use a different port than 80 for http (you will see e.g. 8080 used), but then the browser must specifie “”, because normaly a browser will try 80 as the default for http.

No way to start xinetd… :frowning: same problem…

I suppose you solved the portnumber question? Else all is in vaine.

Then I go a little bit backwards. Was xinetd running before you started adding mldonkey to it?

When no then first try this with the default configuration. So first undo all you did on xinetd.conf (probably nothing) and inside xinetd.d (I suppose you put the mldonkey file in there, so mv it to a save place.

Now goto YaST > System > System Services (Runlevel) select xinetd in the list, click Enable ands then Finish.

Now check if it runs with** ps -ef | grep xinetd**
Look with **dmesg **for errors.

When this is OK put the mldonkey file into /etc/xinetd.d and try the restart as you did earlier.

xinetd was not running… so i stared it ( without adding nothing ) I had activate some simple service like vsftpd… In this way start… Mldonkey send xinetd in troubles…

What is the portnumberr you gave mldonkey in /etc/services?

I tried with 80 tcp

I doubt if that is a clever idea, port 80 is the well known port for http. Now it can be used for other services as long as you do not run a http server yourself, but if it is clever? And how do you tell your clients outside to use this port? Also I told you somewhere above you have to use a portnumber >1024 if your server runs as a normal user (and that is the case for marco).

You did not seem to find a portnumber in mldonkey’s documentation. Now I have no idea what mldonkey is and how it works, but a little googling brought me to MLdonkeyOptionsExplained - MLDonkey. Is that usefull?

And doublecheck if /usr/bin/mldonkey is executable by use marco.

Yes, mldonkey is executable by marco