xine errors with kaffeine

I’m trying to load up a DVD which is on my hard drive (so basically just a directory). Whenever I do this I’m given the error: “xine: Can’t init Video Driver ‘opengl’ - trying ‘auto’…”

This is on a Dell Inspiron E1705 with an ATi Mobility Radeon X1400. My xorg.conf file lists the device section as

Section "Device"
  BoardName    "Mobility Radeon X1400"
  Driver       "radeonhd"
  Identifier   "Device[0]"
  Option       "monitor-PANEL" "Monitor[0]"
  VendorName   "ATI"

Any other info I should be providing?

Try the following in kaffeine: Open settings and choose Xine engine parameteres. Select video from the icon bar on the left. Select a new driver. Try Xv or Xshm. Hopefully at least one of them should do the trick. If that fails, check to see that you have installed the w32-codecs package from the packman repo.

That appears to have done it. Thanks.

Interesting bit of trivia: the version 0.9.0-pre-alpha (KDE4) doesn’t allow for changing those settings. I was only able to do so in 0.8.7 (KDE3).

if you are running the gstreamer backend for phonon you can change it by running “gstreamer-properties” and setting video out the driver that worked for you. If, like me, you are running KDE, then you need to install the gnome-media package to get the gstreamer-properties program.