xfig can find fonts in suse 11.2

I installed the new suse 11.2 on my laptop. To draw things I use the very good vector graphics program xfig.
But with the new version of suse xfig can’t find the fonts for text input. I always get an error message like this:

Can't find -*-times-bold-r-normal--21-*-*-*-*-*-ISO8859-*, using 6x13

After looking around in some other forums I found out that these fonts are the ghostscript fonts. I have installed the ghostscript on my system but the font pathes seemed to have changed from suse 11.1 to 11.2. But xfig still want’s the old pathes.
Has anybody an idea how to tell xfig the correct location of the fonts.
Thank You

I just solved this problem.
If anybody needs a solution on the xfig homepage you can find an instruction how to install ghostscript’s Type 1 fonts under X.
Getting and Installing Xfig


Thanks for the link! I had the same problem and it’s solved now.
Just to add: I have opensuse 11.2 64 bit edition and in my case the location of the X-server type1 fonts is: /usr/share/fonts/Type1

I’m not an expert in these kind of things and it took me a while to find out, so this might help for people with the same problem… :slight_smile:

I have exactly the same problem:
trying to typesome words on xfig grafics, using opensuse 11.264 bit and got the sameerror message like above.
I can not even use the default font.
Then iam trying todo everything mentioned on the xfig website to install the ghostscript Type1 fonts (i installed the ghostscript pagages before), which means:
copying all the fonts from the ghostscript fonts directory to the other fonts directory (in my64 bit opensuse i just had the path: /usr/share/fonts/Type1 , like Gonzo17 said), then i updated the /usr/share/fonts/Type1/fonts.scale with the lines from the ghostscript fonts.scale and then typed in (as root):
xset fp rehash

but i got the error again. Then i restarted and tried it again -> same error
typed in
xset fp rehash -> same error
typed in:
mkfontdir -> same error
typed in:
xset fp rehash -> same error, what can i do?

Open a console and enter sax2; save the configuration. This will create the correct xorg.conf file which is not created automatically when you install 11.2.

If this does not work, there is a further fix on the xfig site.

i typed in what you wrote (as root) and got the following results:

SaX: initializing please wait...
SaX: access to your display has been granted
Xlib:  extension "XFree86-Misc" missing on display ":0.0".
Xlib:  extension "XFree86-Misc" missing on display ":0.0".
Xlib:  extension "XFree86-Misc" missing on display ":0.0".
Xlib:  extension "XFree86-Misc" missing on display ":0.0".
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.
ISaX: could not import file: /var/cache/sax/files/config at /usr/sbin/isax line 199.
SPP: prepare device [1] profile: vbox-mouse
SPP: including prepared profile(s)...
SPP: prepare device [0] profile: nobus
SPP: including prepared profile(s)...

SaX: startup
SaX: X-Server: :0.0 -> grant
SaX: using cache data...

I saved the configuration, and then opened xfig again and tried to type in a word -> same error.
i typed in xset fp rehash (and so on) but again i got the same error.

What is the further fix on the xfig side, i was not able to find something.

This is the tip I meant: Installing Ghostscript’s Type 1 fonts under X under Getting and Installing Xfig

Thanks but this is what i, and the others in this thread, did. But for me it did not solved the problem.

  • Saw the bug here
  • Reproduced in my machine
  • Fixed in my machine
  • Searched the bug and found https://bugzilla.novell.com/564336
  • Gave a complete description of the problem in the report
  • Assigned to X maintainers and added xfig maintainer CC
  • Expected someone else to have done this before… and now that I did to be fixed in less than a week, at least for 11.3

I was already fixed last year, but not for 11.2. The easy fix? Just run

xset fp+ /usr/share/fonts/URW

before xfig.
You can put it in some init script (~/.xinitrc is recommended) to avoid doing that all the time.

Thanks this helped. But putting the line in the ~/.xinitrc
resulted in that i was not able to login my useraccount anymore (at least i could not login kde). After typing in my password, it loads i while and then puts me back to the login screen.
I had to login as root an remove that file (there were not such file before so i had to create it to put the line in), after that i could log in my user account again.

As always the primary source is the most exact (https://bugzilla.novell.com/558915)

~/.xinitrc would be the right place (use ~/.xinitrc.template as a template).

I have not tried. But probably the easy, correct, system-wide way is to create an script inside /etc/X11/xinit/xinitrc.d the same way “xdg-user-dirs.sh”, that is already there from the xdg-user-dirs package.

I just tried … and am satisfied with the results so far.

I created a new-script.sh file in /etc/X11/xinit/xinitrc.d like this:

xset fp+ /usr/share/fonts/BDF/
xset fp rehash

This got me happily running a remote session of Mathematica. I had already copied the BDF fonts from the server where Mathematica was installed into /usr/share/fonts/BDF on my desktop and run mkfontdir. Hope that helps another noob.