XFi installation problem

i was previously using Ubuntu 8.04 and the card worked like a charm. Sound in wine & amarok @ the same time! I’ve tried openSUSe 11 and know I’m litteraly in love with it but not my audio card :rolleyes:

I has tried to get it working by following this tut Ubuntu Forums - View Single Post - [all variants] Hardy 8.04 & OSS4 (Alternative to ALSA) but it’s deb packages… and I dunno how to install .deb on openSUSE :smiley:

I need GCC 4.3-base but it’s a .deb package and i dunno how to install it… Maybe some help? :o

EDIT: I’ve found dpkg on Yast will give it a try! Can’t get it to work :confused:
Have installed aptitude package but don’t know how to download on the good repo…
Build Service/Deb builds - openSUSE

IMHO rather than mess around with different package manager formats, if you can not find an rpm, then you should compile from source.

A number of openSUSE users on this new merged forum, and also on the older SF and SLS forums have addressed this issue (have the same XFi sound card). I wish one of them would write a “TIPS-and-TRICKS” post, or “HOW-TO” post, or better yet create an openSUSE wiki.

If it were me, I would go here and download the source file from here:
OSS Download Registration

and custom compile.

I don’t think that has anything to do with what you are trying to do.

Thanks for the response but I’ve find a way to install the package that I needed!

Alien to convert the deb to rpm then ctrl+alt+F1 -> root -> init3 -> rpm -i package.ext

Finish the installation that way and wi’ll post a how to :cool:

So I’ve sound on my opensuse11 with the XFi! With all the necessary package listed there Ubuntu Forums - View Single Post - [all variants] Hardy 8.04 & OSS4 (Alternative to ALSA). Converted all of them to .rpm with alien (ea: alien -r esound.deb -> esound.rpm) then installing them in console mode (init 3)

Got the sound working in system must now test when using wine (cs1.6) and amarok @ the same time…

Will do a HOW-To if it work! :slight_smile:

S*** the sound is working in amarok but not in steam!

winecfg “Test sound” button work when steam is not launched but not with steam launched… maybe the 1.0version of wine got a bug :confused:

OKAY so finally amarok and wine can’t work together! Only 1 sound can be streamed at each time… maybe will I switch back to Ubuntu =/

Pulseaudio was supposed to make this functionality between various apps work better. But there are teething pains with pulse audio in 11.0.

It surprises me that wine and amarok can not play audio at the same time, but I don’t use any wine apps that play sound (nor do I intend to) so I can not test this out. Its possible this is a configuration problem on your side.

You have diverged so much from the original Subject, IMHO the odds are that if someone has that working, they won’t see your problem because of the title. Hence other than try to do this all by your self, I don’t see you trying hard here to ask other’s for their experience on this matter (or did I miss a post of yours ?? ).

As for “going back to Ubuntu”, … my view is the same I have for any OS. Go with what works. In fact, if one is happy with Windows, or MacIntosh, or Sun or Ubuntu, Fedora, etc … then don’t leave that OS if one is happy. Go with what works for you. …