xfce4 thunar not responding

A few times the thunar in xfe4 is not responding, i.e., when I double click an folder icon in destop, nothing happens.

I have tried

xfdesktop -R


xfwm4 --replace &

but none of the above worked. Clicking an icon of a file on desktop shows the following error:

The file could not be opened
Thes feature requires a file manager service to be present (such as the one supplied by Thunar)

Most of the plugin in the panel works except Places, no response upon clicking.

After log out and log in , all icons on destop disappeared.

Any ideas on how to debug it? Thanks a lot!

Can confirm. OpenSUSE LEAP 15.2. Brand new laptop, 32GB RAM. Xfwm4 locks at boot after about five seconds and terminals/Thunar stop responding.

Ctrl+alt+F5 to a virtual terminal and killing xfwm4, then Ctrl+alt+F7 into XFCE again fixes the problem. And whatever xfwm4 is, for all intents and purposes the only difference I see in how XFCE is working is that everything started working. If this was Thunar, I’d expect to see all Thunar windows gone, etc, but with xfwm4, I can’t see a difference in what my desktop looks like in XFCE nor can I detect anything that’s not working (i.e. now that I killed xfwm4).

Request information as to how to troubleshoot the problem.

I do not experience the problem in Tumbleweed but I would try to delete old sessions if they were saved from: