xfce4 keeps forgetting keyboard repeat rate

Whenever screensaver blanks the display, the keyboard repeat rate and delay are reset to default value. I always have to run ‘xset r rate …’ manually.

Is there a way how to prevent this from happening?

You need to fully describe the method you use to set your custom settings.
Sounds like you’re not doing it in a way that is permanent (typically edit a config file) and is transient and session-speciic.

TSU

I am using the fxce4-settings-manager -> keyboard. This is on a fresh installation.