XFCE walpaper not showing when it should

Here is my setup:

openSuse 13.1

The rest is stock.

I have tried to modify a few things like login background photo but ended up with a problem with gray screen poping up just after the login page and before the wallpaper. This didn’t happen on LXDE. Here at XFCE people have sugested me that something is wrong: https://forum.xfce.org/viewtopic.php?id=8481 and that the wallpaper should pop up first. How to inwestigate?

Are you using lightdm?

Have a look at this threrad

Not sure enough if that is what you want to achieve.

I don’t know what it is but I have managed to set up the wallpaper for the login page - it shows up as needed. I also could change the home screen wallpaper. The problem is like this:

the system boots - the login background shows up (my custom which is ok) - I type the pasword - grey screen pops up, the menu icons are loading - the wallpaper is poping out.

The problem is with the grey thing loading before the wallpaper - as sugested in XFCE the wallpaper should be there first, and then the icons should load.

I see, sorry but I have no answer for that.
I see it sometimes when xfdesktop is slow to load.

In the xfce settings, in desktop set the colors in transparent see if that change the behavior.
If not maybe something went wrong when you modify the login screen image.

I just followed a simple tutorial in which I commented out the stock login screen image and added my.

The transparent setting didn’t help.

I had this problem since day one on a stock xfce install of 13.1 - I can only add that the whole disc was wiped clean before install.

Does this qualify as a bug to be reported?

I’d be willing to bet that you have the Xfce compositor turned on in Window Manager Tweaks. I had same problem and fixed it by turning it off and using ‘compton’ composite manager.
Then add to startup applications Compton with these parameters

compton -c -f -C -b

Works great.