XFCE power manager not showing


I have used XFCE for more then a year and now did a fresh install and moved to Tumbleweed.

The power indicator worked flawlessly but now it doesn’t load at start and when I unplug the cable when I load it manually it doesn’t show that I’m on a battery.

I have found this:


Maybe an update could be pushed to openSuse to fix this?

I couldn’t find a special package but it’s apparently been accepted into mainline XFCE so should likely appear in the next major update to XFCE.

Just update regularly, and sometime soon hopefully it’ll show up

zypper up


I understand but how is it possible that it was all working? On my last XFCE Tumbleweed setup it all worked and on a clear one it stopped…

According to the bug report, the XFCE power manager didn’t support upower-0.99. But upower got updated to 0.99 in Tumbleweed 22 days ago AFAICS. Before that you had the standard 13.1 version installed, which is 0.9.23, therefore xfpm worked fine.

The new xfpm version won’t automatically appear in Tumbleweed though. Probably it will be included in openSUSE 13.2 (and therefore in Tumbleweed when 13.2 has been released, which is planned for November).
But if you want it earlier, you should file a bug report with openSUSE, so that they might update the package xfce4-power-manager.
http://bugzilla.novell.com (same password/username as here).

Or at least write an email stating the issue to opensuse-factory@opensuse.org, which is the development mailing list for Factory and Tumbleweed.

A fixed package for Tumbleweed is available here btw:

I’m not that brave to instll packages that are not in the repos. It is my work PC so have to be carefull.
I have filled a bug here: https://bugzilla.novell.com/show_bug.cgi?id=852004

But it is in a repo.:wink:

And the currently installed package does not work at all anyway, so what do you have to lose?
But it is your decision of course…

I have filled a bug here: https://bugzilla.novell.com/show_bug.cgi?id=852004

That bug is about changing the icon theme in LXDE AFAICS. I suppose you posted the wrong URL and mean this instead: https://bugzilla.novell.com/show_bug.cgi?id=878483 :wink:

PS: You should better also point to the upstream bug report/fix in your openSUSE bug report.

You are right. I’m not that good in bug reports as this is my second :wink: You are also right with the link - my bad!

With the third bug report I will be better.

With that repo I meant that it is not an official one adn it is a private person one - something like with pipelight repos. Am I right or I have mixed something? I like to install software from official repos

On 2014-05-18 07:46, Wurger wrote:
> I like to install software from official repos

The entire tumbleeweed is a sort of experiment :wink:

I doubt to classify it as “official”. It is the stupendous effort of a
single chap.

Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

FYI (if you haven’t noticed already anyway :wink: ), XFCE (including an updated xfce-power-manager) has now been added to the Tumbleweed repo, so the issue should be resolved.


Everything works!

Thank you all for helping me!