Xfce panel disappears when Compositing is enabled

When I enable display compositing in Xfce, my panel disappears and appears only when the mouse cursor is in over the area where the panel is ( or should be ).
And no, the panel is not set to hide automatically, and without compositing it works as it should.

My specs are: openSUSE 11.4 32bit, NVidia 9500M GS, NVidia 270.41.06

I finally figured this one out! It’s been bugging me since June or so. Ok, so here are the steps to fix this:

  1. Enable display compositing
  2. Right click on panel -> Panel -> Panel Preferences
  3. Switch to the Appearance tab
  4. Change the “Leave” Opacity to something you like. If you don’t want the panel to change when your mouse leaves its area then make sure that Enter and Leave Opacity are the same.
  5. Finally!

This was my first thoughthttp://www.kread.info/g.php