XFCE - Konqueror cannot doube-click to open video files or office files

Hi,

In a 42.2 , XFCE Desktop, Konqueror cannot doube-click to open;

  • video files ( mp4)
  • office files ( odt, ods )
  • pdf
  • txt files ( message KDEInit could not launch /usr/bin/kate )

But;

Double clicking on a jpg, png files , opens that file inside konqueror itself.

Note1: Right-clicking on a file and choose an app to open in does not work for all types
of files.

Note2: Dolphin works fine however.

Q : How do i get konqueror to open files by double-clicking on them ? or right-clicking on them ?

Thanks.

Well, you obviously don’t have kate installed, though it seems to be set as standard application for txt files.
What happens for the others?

Double clicking on a jpg, png files , opens that file inside konqueror itself.

Yes, Konqueror opens certain file types directly in its window, that can be configured in its file types settings.

Note1: Right-clicking on a file and choose an app to open in does not work for all types
of files.

Can you be more specific?
For what types does it not work, how does it not work?
(e.g. do you get an error message, are there no applications shown, or what)

Note2: Dolphin works fine however.

Dolphin is a Qt5/KDE Frameworks5 based application, but Konqueror is still KDE4 based in 42.2.
The main difference I’d consider to be related here is that KDE4 stores the default applications in ~/.local/share/applications/mimeapps.list, while KF5 follows the newer standard (like XFCE does) and uses ~/.config/mimeapps.list .

So either copy the latter over the former, or reconfigure your file associations in Konqueror.
(right-click on a file and choose Properties, then click on the file type icon to change the associations, or go into Konqueror’s settings)

You might also have a look at https://wiki.archlinux.org/index.php/default_applications#XDG_standard for more information.

Hi,

My replies below;

Kate is installed.

Can you be more specific?
For what types does it not work,

  • video files ( mp4)
  • office files ( odt, ods )
  • pdf
  • txt files ( message KDEInit could not launch /usr/bin/kate )

how does it not work?
(e.g. do you get an error message, are there no applications shown, or what)

Double clicking on them -> no error message, no app opens.
Except if its a text file, for which , we get “KDEInit could not launch /usr/bin/kate”

Dolphin is a Qt5/KDE Frameworks5 based application, but Konqueror is still KDE4 based in 42.2.
The main difference I’d consider to be related here is that KDE4 stores the default applications in ~/.local/share/applications/mimeapps.list, while KF5 follows the newer standard (like XFCE does) and uses ~/.config/mimeapps.list .

Noted.

So either copy the latter over the former, or reconfigure your file associations in Konqueror.
(right-click on a file and choose Properties, then click on the file type icon to change the associations, or go into Konqueror’s settings)

You might also have a look at https://wiki.archlinux.org/index.php/default_applications#XDG_standard for more information.

Ok will try that.

Really?
Can you run it on its own?

Your error message does suggest something else:

Except if its a text file, for which , we get “KDEInit could not launch /usr/bin/kate”

It might also be caused by wrong command line arguments though.
Also kate is KF5 based meanwhile, your KDE4 file associations might still point to the KDE4 version and/or use arguments that are no longer supported.

Your problems with other filetypes might have similar reasons.

Hi, my replies below…

Yes, I can.
Via ;

  • Menu -> Accessories -> Kate
  • Menu -> Development -> Kate
  • Terminal -> type in “kate” and enter

Your error message does suggest something else:
It might also be caused by wrong command line arguments though.

I have;

  • Menu -> Accessories -> Kate ==> kate -b %U
  • Menu -> Development -> Kate ==> kate --new

Also kate is KF5 based meanwhile, your KDE4 file associations might still point to the KDE4 version and/or use arguments that are no longer supported.

Your problems with other filetypes might have similar reasons.

So , rename the .kde4 folder ?
Pls note that this box was not a direct install of 42.2 but an upgrade over 12.2 and then 13.1.

Dolphin is a Qt5/KDE Frameworks5 based application, but Konqueror is still KDE4 based in 42.2.
The main difference I’d consider to be related here is that KDE4 stores the default applications in ~/.local/share/applications/mimeapps.list, while KF5 follows the newer standard (like XFCE does) and uses ~/.config/mimeapps.list .

So either copy the latter over the former, or reconfigure your file associations in Konqueror.
(right-click on a file and choose Properties, then click on the file type icon to change the associations, or go into Konqueror’s settings)

Both methods tried - Problem still persists.

Good, so at least Kate itself works.

  • Menu -> Accessories -> Kate ==> kate -b %U
  • Menu -> Development -> Kate ==> kate --new

Hm, the second one is definitely not standard… (at least it’s not shipped by KDE AFAICT)
Both of them should work though. (although the second one doesn’t allow to open a file with it, it just opens a new Kate session)

But what is set for the affected file types in Konqueror’s settings? (file management->file associations)

So , rename the .kde4 folder ?

No, that likely won’t help here.
But you could try to rename ~/.local/share/applications/ (this will also remove self-created application menu entries though, if you have some) and ~/.local/share/mime/ (which contains custom file associations and mime types).

Pls note that this box was not a direct install of 42.2 but an upgrade over 12.2 and then 13.1.

This might play a role here, yes.

Both methods tried - Problem still persists.

Well, have you tried a fresh user account?
Should rule out a problem with the user settings.

Well, have you tried a fresh user account?
Should rule out a problem with the user settings.

Thats something i could try.

What do I need to copy ?

I use;

  • thunderbird for email ? so .thunderbird
  • firefox , so .mozilla

And my data files, etc.

Right ?

Depends on what you need… :wink:

But if you copy too much, you might just copy the problem too.

Actually the intention is to see whether the problem is related to the user settings or somehow more general, not to have you starting to use a new user account completely.

So I’d rather suggest to not copy over anything, but just create a new user account and try if the problem occurs there as well.

Just noting that the @OP said he’s installed Konqueror in an XFCE Desktop.

By default, XFCE is built on a lightweight Gnome pattern, not KDE.

I’d ask the @OP if he might consider using PCManFM instead of Konqueror? PCManFM is the default file manager for XFCE.

TSU

That’s clear, but doesn’t really help with the question… :wink:

There obviously are reasons why he wants to use konqueror.

True,
But, based on his result

  1. If he didn’t know better just choosing XFCE rather than KDE in a new install, he might just use PCManFM if the functionality works(and I assume there would be no problem).
  2. If PCManFM works, then it might further narrow down approximately what subsystems are missing that might provide that functionality for Konqueror. Ordinarily, installing Konqueror should have installed the necessary KDE dependent subsystems, but a File Manager is not just any app, it probably is more integrated into numerous KDE subsystems than more “typical” apps with more limited functionality. And, I guess since openSUSE strives to provide full cross-Desktop functionality in alien Desktops, would possibly suggest comparing dependent sub-systems and/or patterns.

IMO,
TSU

Right, I suppose that’s the case.

  1. If PCManFM works, then it might further narrow down approximately what subsystems are missing that might provide that functionality for Konqueror. Ordinarily, installing Konqueror should have installed the necessary KDE dependent subsystems, but a File Manager is not just any app, it probably is more integrated into numerous KDE subsystems than more “typical” apps with more limited functionality. And, I guess since openSUSE strives to provide full cross-Desktop functionality in alien Desktops, would possibly suggest comparing dependent sub-systems and/or patterns.

Sigh.
That’s what I try to investigate here.
Your comments don’t help at all though.

Konqueror , IMO , is one of the best open source software ever.
My particular fav feature is support for fish ( ssh gui ). Not available in Pcmanfm yes ?
Next, konqueror is also a web browser …
Support for multi column bookmarks.

Dolphin has support for fish though.

Guys, after i renamed .kde4 folder , konquerer seems to have regained the ability to open files ( odt, pdf ,mp4 ) in the appropriate application when the files are double-clicked. WHAT A RELIEF !

Next, Pls look at the attached screenshot - the icons seem to be missing on the front page.
Any ideas ?

Url : http://uploads.im/FvtmA.png

Some *.svg files missing ?

I forgot to mention one thing yesterday:
The problem might be that KDE4’s cache of installed applications was outdated or corrupted.
Running “kbuildsycoca4 --noincremental” as user should fix that.

You already found a “solution”, but maybe try to rename .kde4 back and run that command instead.

Next, Pls look at the attached screenshot - the icons seem to be missing on the front page.
Any ideas ?

Url : http://uploads.im/FvtmA.png

Some *.svg files missing ?

The problem is indeed related to .svg files.

They are not missing, but KHTML (Konqueror/KDE’s original web rendering engine that is still used to display the introduction page) cannot display SVG graphics at all. (I fixed that some weeks ago, but there hasn’t been an update for 42.2 yet)

The new breeze icon theme only consists of SVG files though.
Switching back to the older oxygen theme (that was default in KDE4) should fix that.
Open ~/.kde4/share/config/kdeglobals and add these lines (or modify them accordingly):

[Icons]
Theme=oxygen

Your old one probably had that anyway, as Konqueror is using the oxygen icons for the toolbar on your screen shot (apparently the icon cache hasn’t been updated since you deleted the .kde4 folder, the introduction page loads the files directly)

Thanks. Will do and revert later.

[QUOTE=wolfi323;2838917]I forgot to mention one thing yesterday:

The new breeze icon theme only consists of SVG files though.
Switching back to the older oxygen theme (that was default in KDE4) should fix that.

Open ~/.kde4/share/config/kdeglobals and add these lines (or modify them accordingly):

[Icons]
Theme=oxygen

THIS WORKED !!!
THANKS x 1000000000000000000000 !!!

Update:

  1. Despite creating a new .kde4 folder ( by just renaming the existing kde4 folder ) the issue still persisted. Double clicking on a file to open it in its native application
    only worked when we login / first time but stopped working afterwards. Would only upon when we login.

  2. Running “kbuildsycoca4 --noincremental” as user - did not help too.

Solution :

  1. Had to create a brand new user account and copied over my data ( including .mozilla , .thunderbird , .ssh )

  2. But surprisingly , the konqueror intoductory page was still missing its icons.

    Will attempt to fix via ~/.kde4/share/config/kdeglobals and add these lines (or modify them accordingly):

    [Icons]
    Theme=oxygen

Over and out.

Hm, that’s exremely strange though.
No idea why that would happen.

Will attempt to fix via ~/.kde4/share/config/kdeglobals and add these lines (or modify them accordingly):

[Icons]
Theme=oxygen

Yes, the default is breeze since 42.1.

Just marking this as SOLVED. But couldnt edit the Thread Title to mark it as SOLVED.