xfce crashes on launching applications (particularly Firefox but others too)

This will be the last thread I start on xfce on Tumbleweed because I’m about ready to give up on it. I managed to install xfce using the directions here: https://forums.opensuse.org/showthread.php/531433-How-to-install-xfce-in-Tumbleweed

The problem I am having now is that applications launch to blank black windows. Sometimes even the application menu is black. I can close the windows, but then I find that xfce has frozen up and I have to do <ctrl> <alt> <backsp> to get out. What’s weird is that for a split second when I am leaving xfce using that combination, I see the applications as they should appear.

I’ve tried removing xfce and reinstalling it. I’ve tried removing the xfce4 directory in .config in my home directory. None of this works.

Any help or ideas will be greatly appreciated.


Well, I’m open to the possibility, but I have not had any problems with GNOME nor with KDE. I also really haven’t had any video driver problems since I’ve been using Tumbleweed.

If it’s the video driver then it’s going to be a tough nut to crack. I am using a laptop running an AMD processor with integrated R7 graphics. AMD doesn’t specifically make a driver for my system so I have to go with the default Linux driver.

By the way, I remember back in the old days (pre-openSUSE, just SUSE), there was a video (or display) option in Yast under hardware. Now that appears to be gone and there doesn’t seem to be a way to try out different drivers from Yast. Am I right about this?

Thanks for your idea. Much appreciated.

I will guess that you are using the default Display Manager with XFCE, which would be LightDM.

When I have something like that happening, my first action is to switch Display Managers and see if the problem goes away.

This has worked for all of the last few cases I have run into on my machines for the past year or so, which is why I often suggest others try it.

For me, I have been lucky that was exactly the problem.

So, to change, do:

su -

That is the minus sign after su, for those following this thread who are relatively new.
You will be asked for root password.

update-alternatives --config default-displaymanager

Choose xdm or kdm in the dialogue.

If kdm is not there, just try xdm. If xdm does not work, use the Yast Software module to install kdm and test again.

Good luck.

Thank you so much for your suggestion! I thought we had it because I know what a difference changing the display manager can do but it didn’t occur to me in this situation. Unfortunately, it didn’t make a difference in this case.

It’s strange because not all applications cause this to happen. The ones that do are most notably Firefox and Dragon Player though I am sure there are others. On the other hand, Chromium works normally, the file browser works normally, and so does the terminal emulator. I can open up all the settings in the settings menu (and there seems to be a lot more settings than in GNOME) without any problems.

To test changing the display manager, I opened up Dragon Player. This time it didn’t open up to a blank black window, but it opened up to just the transparent outline of the window with the X in the upper right-hand side as it normally is. I clicked “X” to close the window outline and it closed, but then xfce was frozen again and I had to do the <ctrl> <alt> <backsp> to get out.

Thanks again for your help. It was an excellent idea that just didn’t work out.

Sounds like (I think) a GTK issue.

Maybe with luck Wolfi (or one of the others) will step in here.

I changed the display manager once again but this time to gdm. With gdm, it is impossible to log in to xfce. It just hangs at the login screen. I went back to lightdm.

I also installed LXDE to see if it were any different. It turns out that LXDE has exactly the same problems as xfce, i.e. it crashes when certain programs such as Firefox are launched.

The question I’m asking myself right now is why I never had any problems with GNOME or KDE, but xfce and LXDE are unusable.

This still looks like a graphics driver problem to me.
An application should never be able to crash the whole session…

Please post /var/log/Xorg.0.log and the output of “glxinfo|grep render” (after you installed the package Mesa-demo-x if it’s not installed already).