XFCE and LXDE Desktop icons text overlap/don't wrap when filename is long

Hi guys

I’ve been using openSUSE for almost 8 years, both regular and rolling versions and this problem showed up few weeks ago. It didn’t bother me at first, but it caused some problems for my father:

Problem: Noticed that after some Tumbleweed update during the last weeks (or months maybe, it wasn’t a problem for me until my father complaining) made the text under the desktop icons not wrap correctly if filename (folder name) is longer than 14 chars (12 chars plus extension if is a known extension) and has no spaces, underscores (_), dashes (-) anywhere on the first 14 chars… Also, if filename/foldername is longer than 14 chars (or 12.ext), if you click on top of it, it won’t appear as if it was selected.

Found this problem first ocurring on XFCE on an up-to-date Tumbleweed installation… Tried to install LXDE as a workaround, but same problem happened. Checked my notebook, which is also an up-to-date Tumbleweed installation from last month but with LXDE only and same problem happens

Maybe is better to explain with examples:

Control group:

  • Filename is “abcdefghijklmn” (14 chars) - No problem happens
  • Filename is “abcdefghij.klm” (10.3 chars unknown extension = 14 chars) - no problem happens
  • Filename is “abcdefghijkl.txt” (12.3 chars known extension) - no problem happens

So, I’ll work with the first filename example: lets create a file named “abcdefghijklmnopqrstuvwxyz”, which is 26 chars long on the Desktop.
Just click it and you’ll see that “nothing happens” as it appears to not be selected. But just hit enter and you’ll see that it was selected because it’ll try to open.

Now, pick the same file “abcdefghijklmnopqrstuvwxyz” and add a space, dash or underscore to its name. I’ll work with the dash “-” as example and here’s what will happen:

  • If the dash is exactly the 14th char, The filename will wrap to a second line just after the dash, the second line will have 13 chars truncated with “…” (if you just delete the z, having 12 chars on the second line, it will not truncate). The behavior when you click the file will be normal.
  • If the dash is put anywhere from the 1st to the 13th char: The filename will also wrap to a second line just after the dash, the second line will display 10 chars truncated with “…”. The behavior when you click the file will be normal.
  • If the dash is put as the 15th char or after: The filename will also wrap to a second line just after the dash, the second line will display up to 12 chars (or 10 chars truncated with “…”). If you click it, You’ll get no clue if the file is selected or not.

The above happens on openSUSE Tumbleweed with XFCE or LXDE on Desktop. The problem also happens on file explorers, such as pcmanfm. And it’s even worse :frowning:

So, I checked on the openSUSE Leap 42.3 with LXDE that I use at work. If I have a filename “abcdefghijklmnopqrstuvwxyz”, it will automatically wrap it after the 13th char and will fully display the filename as “abcdefghijklm” on the first line and “nopqrstuvwxyz” on the second line. If you add a char, to make it more than 27 chars long, it will always split to 13 chars on the first line and 10 plus “…” truncated second line.

PS: It seems that it also depends on fontsize and char lenght… if filename is only “iiiiiiiiiiiiiiiiiiiiiiiiii” it won’t have problems, despite being 26 chars long. “aaaaaaaaaaaaa” will have problem even if it’s only 13 chars long.

I asked a friend to see his Debian testing installation with XFCE. On his case, long filenames are truncated on the very first line, displaying few chars.

I’ve searched if there’s anyway or some setting that I could change so it would reverse to the settings as it was before, but couldn’t find anything. I’ve found some people complaining about it on the past and they were talking about editing a “~/.gtkrc-2.0” file - https://git.xfce.org/xfce/xfdesktop/tree/README - but since I never changed anything related, I think that maybe someone messed up with the default settings for Tumbleweed. I tried the above suggestion, but it didn’t work for correctly wrapping or truncating the text.

What is the problem with long filenames like “abcdefghijklmnopqrstuvwxyz” not wrapping or getting truncated at openSUSE Tumbleweed on XFCE or LXDE? (Tumbleweed up-to-date in 11-27-2017). Worked fine before some update in last few weeks/months.

Update: Installed KDE just to see… KDE works fine. It seems that is GTK settings related

Fixed on Tumbleweed update 20171204… It seems it was something to do with libpango - https://bugzilla.opensuse.org/show_bug.cgi?id=1070185