When I start the virtual machine manager I get the following error:

Unable to open a connection to the Xen hypervisor/daemon.

Verify that: -A Xen host kernel was booted -The Xen service has been started


Unable to open connection to hypervisor URI ‘xen:///’:
<class ‘libvirt.libvirtError’> virConnectOpenReadOnly() failed
Traceback (most recent call last):
File “/usr/share/virt-manager/virtManager/connection.py”, line 325, in _open_thread
self.vmm = libvirt.openReadOnly(self.uri)
File “/usr/lib64/python2.5/site-packages/libvirt.py”, line 144, in openReadOnly
if ret is None:raise libvirtError(‘virConnectOpenReadOnly() failed’)
libvirtError: virConnectOpenReadOnly() failed

Any ideas?

Did you boot openSUSE selecting the Xen kernel in the boot selection?

If I choose the Xen (version # info) option, when I try to launch the virtual manager it just opens and closes very quickly.

Actually, you don’t need it. Just manage with xm.

xm start <Domain>

vncviewer localhost:0

Run :-

man xm

I confirm virt-manager collapses immediately when :-

xm info

brctl show

are good

they are probably working on your issue here : https://bugzilla.novell.com/show_bug.cgi?id=398932

the xm commands dbaxps mentioned should give you enough tools for now to get things running.

Next to the man pages type ’ xm --help ’ for a list of possible commands.

‘xentop’ and ‘brctl show’ are also valuable commands.


got my links mixed, meant to post this one: https://bugzilla.novell.com/show_bug.cgi?id=402075

I’ve just setup 11.0 with Xen here getting the same results.
dmesg shows :
/usr/share/virt[5555] trap divide error ip:7f69c63c05ac sp:7fffdb0eb9a0 error:0 in libvirt.so.0.4.0[7f69c639f000+5e000]
/usr/share/virt[5562] trap divide error ip:7f0bc9e6b5ac sp:7fffdeb95450 error:0 in libvirt.so.0.4.0[7f0bc9e4a000+5e000]

So the first link does seem related!

Is this issue resolved yet? I installed xen yesterday and got exactly the same error message (Unable to open connection to hypervisor URI 'xen…).The updated libvirt seems to have no effect.

Solved ! Once you boot into Xen, you have to login as root.Then the virtual machine manager displays all the VMs including dom0

…but in order to even access Xen, you have to go through YaST, which requires a root logon. When I try to create a machine it reports “Hypervisor is not running.” I’ve an x86_64 and running a Xen kernel.

This might sound stupid but after installing xen through yast, have you actually rebooted into the xen kernel ? Hypervisor does not run if u boot into the normal kernel.

Here is a step by step tutorial to xen.